Unable to upload file to Google Drive from WordPress

What is the problem you are having with rclone?

I cannot upload the attachment on WordPress after I have mounted the Google Drive Folder on my server. The folder is granted permission to be 777/root is still unsuccessfully uploading the attached to the Google Drive from WordPress.

Error Message on WordPress:
232286286-hd-sea-wallpapers.jpg
The directory uploads/2021/06 could not be created. Do you have the write permission of the upper-level directory?

What is your rclone version (output from rclone version)

v1.55.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04.2 LTS 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

hello and welcome to the forum,

when you posted there was a template of questions.
without that information, we do not have enough info to help you.

please post:

  • rclone command
  • rclone config file, redact secret/id
  • rclone debug log

No command you are running.
No log file.

Seems like you have a permissions issue from the error you posted.

Yes, you are right.

I am facing a permissions issue from the error I posted.

Please advise me on how to fix this problem to be resume.

Thank you so much.

By sharing the info in the template as we don't know what you are running.

What command I should type on the server to provide the log?

It's in the template you deleted.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

You should use 3 backticks to begin and end your paste to make it readable.

Paste command here

The rclone config contents with secrets removed.

You should use 3 backticks to begin and end your paste to make it readable.

Paste config here

A log from the command with the -vv flag

You should use 3 backticks to begin and end your paste to make it readable. Or use a service such as https://pastebin.com or https://gist.github.com/

Paste  log here

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.