Unable to remove network drive. Please guide me

What is the problem you are having with rclone?

I am unable to remove a network drive I created. My problem is that I intended to make a network drive Z: but, instead, Windows Explorer shows I created a network drive called xxx.yyy.ppp.qqq that I am unable to get rid off. The config file I show below is not what I started with and I do not remember exactly what I did to get to where I am. All I want now is to remove this silly drive and start over again. The silly drive was not and is not usable the way things are now.

When I select that drive in windows Explorer I get the message
"A connection with the server could not be established".
I remember I did not do a cntrl-c in the cmd window to disconnect it; I killed the window instead. The drive persisted and is till there even after reboot. Uninstalling winfsp did not help.
There was no log file created; I did not tell it to create one.

Initially I gave the command (without --config Desktop\rclone\rclone\rclone.conf):

PS C:\Users\justme> Desktop\rclone\rclone.exe XXX:xxx.yyy.ppp.qqq z:

I got the message that default config was used; and Windows Explorer showed a drive without a drive letter but as xxx.yyy.ppp.qqq. I am listing what is hopefully helpful information below. I found a rclone.conf file in the Appdata\Roaming\rclone\ directory but it was empty. The rclone.conf file I show below is not what rclone started with.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: Microsoft Windows 10 Home 22H2 (64 bit)
  • os/kernel: 10.0.19045.4046 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

None. I am using my own sftp server xxx.yyy.ppp.qqq.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I was on windows. I did not issue a command to unmount; I just exited the cmd window. That did not unmount the drive with a command. I did not do ctl-c either.

Please run 'rclone config redacted' and share the full output. If you get

PS C:\Users\justme> .\Desktop\rclone\rclone.exe config redacted
type = sftp
host = xxx.yyy.ppp.qqq
user = XXX
key_pem = XXX
ssh = ssh -i 'C:\Users\justme\.ssh\XXX' XXX@xxx.yyy.ppp.qqq
known_hosts_file = ~/.ssh/known_hosts
shell_type = none
skip_links = true
idle_timeout = 10m0s
PS C:\Users\justme>

A log from the command that you were trying to run with the -vv flag

backticks to begin and end your paste to make it readable. Or use a service such as https://pastebin.com or https://gist.github.com/ -->

I did not try to run a command; I just killed the CMD window to unmount.

This is the current rclone.conf file

type = sftp
host = xxx.yyy.ppp.qqq
user = XXX
key_pem = XXX
ssh = ssh -i 'C:\Users\justme\.ssh\xxx' XXX@xxx.yyy.ppp.qqq
known_hosts_file = ~/.ssh/known_hosts
shell_type = none
skip_links = true
idle_timeout = 10m0s

To mount your remote as a network drive you should run:

rclone mount FFFFF: Z: --network-mode

or with some extra flags which are essential for smooth performance:

rclone mount FFFFF: Z: --network-mode --vfs-refresh --vfs-cache-mode full

In terms of your "network drive called xxx.yyy.ppp.qqq" I have no idea what you did but sounds like you created some network mount with "reconnect after reboot" option on. Simply disconnect it permanently.

You are correct I had the "mount" command. The xxx.yyy.ppp.qqq is just a four byte domain. I misunderstood the documentation. I will check it out. Thanks.

It is not really rclone problem as this rclone mount is not even running anymore. Do what normally you would do with any other network drive on Windows to disconnect it.

I tried that with windows file explorer. A windows dialog box poped up asking me to select the network drive to disconnect but the list it gave me to chose from was empty.

Because maybe it is not a network drive at all. Can you check OS startup logs what is creating it? I am not Windows user so not sure can help more here.

It is nothing mounted. It is just shortcut to network location. You can ignore it.

It has nothing to do with rclone.

It might not be damaging. There must be a way to remove it; and I do not know how I did it.

Ask on Windows forums or Google. You tried to access this network address and Windows does you a favour and remembers it for future use:)

Sorry for the delay; other pressing things are going on.

I am not sure I understand this question. I ran "net use /delete"; is this the command you want? I do have admin rights on this machine. The machines never complained about rights.

All I did before was open a cmd window and issue the rclone mount command. I did not give any elevation command. I now opened a new cmd window the way I did for the mount command and issued the following command:

net use

New connections will be remembered.

There are no entries in the list.

Yes; it is the same. There was no typing mistake. I copied and pasted with a mouse.

I have not used the --network-mode option.
I am not competent enough to do debugging. I would be glad to answer questions and help anybody trying to debug this. I will file a bug if somebody confirms that this is a bug.

There is no any bug - at least you have not provided any evidence of one. You just have to learn how to use your OS - how to manage network locations. This has nothing to do with rclone.

Try Google - there should be plenty of info there.

I will take your word for it; the network drive that came about because I used (or maybe misused) a rclone command is not a rclone issue.

I have always regarded that Microsoft Windows to be a big virus and stayed away from it. It has become an evil that we have to live with; but that is traumatic.

If you would help me I promise never to use Windows again.

1 Like

Hahahahaha. You made me laugh.

It is not so bad - like any tool it requires some knowledge. More you learn easier it becomes.

It is the same with any other OS. Do not think that grass is greener somewhere else:)

As soon as you start doing more than browsing web and arranging pictures from your camera things are becoming more challenging. Always and everywhere.

That pop-up was empty. There was nothing to select.

For some reason unknown to me, the slash between "justme" and ".ssh" is not showing in my reply. However, it shows when I am editing.

Because you do not format your posts - and they not only look ugly, are difficult to read but also might miss some characters.

Enclose data in ~~~:

my data
my data

will look

my data
my data

then it will use fixed width font - much better for any config, log etc. vs variable width much better to write stories. Also all characters are printed as they are.