Unable to list files in my Team Drive

What is the problem you are having with rclone?

I have configured the rclone with my service account for backup data from google team drive. I have shared my complete team drive with the service account email and also enabled domain wide delagation

What is your rclone version (output from rclone version)

rclone v1.52.1

  • os/arch: linux/amd64
  • go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/arch: linux/amd64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls gdrive:

The rclone config contents with secrets removed.

type = drive
scope = drive.readonly
service_account_file = /gdrive-backup/config/service-account.json
upload_cutoff = 1G
chunk_size = 32M
v2_download_min_size = 32M
team_drive = xxxxxxxxxxxxxx
shared_with_me = true
root_folder_id =xxxxxxxxxxxxxx

A log from the command with the -vv flag

2020/06/18 13:15:13 DEBUG : rclone: Version "v1.52.1" starting with parameters ["rclone" "-vv" "ls" "gdrive:"]
2020/06/18 13:15:13 DEBUG : Using config file from "/home/ubuntu/.config/rclone/rclone.conf"
2020/06/18 13:15:14 DEBUG : Google drive root '': read info from team drive "Test drive"
2020/06/18 13:15:14 DEBUG : 6 go routines active

This only returns items shared with you. You'd want to remove that.

1 Like

I have tried with setting shared_with_me = false and still, it's not working.

Try with adding:

--drive-root-folder-id ""
1 Like

Yes, It worked, Thanks

shared_with_me = false
root_folder_id =

Should be fixed soon.

That was a new item that popped up:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.