Unable to find flag to prevent deleting files which are 30days old with read and write permission to the mounted blob

I am using rclone mount to mount Azure blob, the problem I am facing is it is removing files if they are getting 30days old, while I have not used any other flag apart from --vfs-cache-mode full and the deleted files which rclone is removing are not capturing in the logs. Also I am not able to see any flag which could disable deleting files from the mounted blob. There should be a flag in which we can define that it should not delete any files. Note: I don't want to use --read-only permission.

It's oddly called --read-only on the mount :slight_smile:

I already mention I don't prefer using that. Is there anything else apart from this?
If so, then please let me know. thanks

How do you mean rclone is deleting files? From the cache? Or from the Azure blob storage.

What parameters are you using to rclone mount

Why don't you want to use --read-only - that is the correct flag to use?

In the log here it is removing the virtual directory -
2023/04/20 05:31:45 DEBUG : Folder_name: Removed virtual directory entry vDel: "File_name_20230319"

Now after that this file is no more found in the Azure blob storage.

I am using NSSM to make rclone mount my blob permanently -

mount azureblob:container_name /mnt/local/path --log-file=log/file/path/logs.txt --log-level DEBUG

The purpose of using rclone mount is to mount my Blob Storage to the server as a File System so whatever files are dropping at that path in server should appear immediately in the blob storage. So --read-only flag won't provide me such privileges.

Which version of rclone are you using? Have you tried the latest beta?

Can you tell me what you did to make that log appear?

Can you show the whole log? If it has confidential stuff you don't want to make public then please share with nick@craig-wood.com - thanks.

I am using rclone: Version "v1.62.2".

To make logs appear - I've used --log-file=log/file/path/logs.txt --log-level DEBUG

Sure, I will ping you log files shortly in your mail, thanks

Thanks for the log.

It appears you are creating files and removing files on the remote and that message DEBUG : Folder_name: Removed virtual directory entry vDel: "File_name_20230319" is normal when a file has been deleted.

This might be a file system compatibility issue. You can make rclone more compatible by using --vfs-cache-mode writes or if that doesn't work --vfs-cache-mode full

If that doesn't work then I'll need more info on how to re-create the problem.


Earlier I was using --vfs-cache-mode full but as it started removing the files, I switched to --vfs-cache-mode writes but it keeps deleting those files. So, now I've removed --vfs-cache-mode flag but still it is removing the files. It didn't work for me. Please note it is only removing exactly 30days old files. thanks for advice.

I think this is your application, not rclone. I can see in your log that the application deletes the files.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.