Unable to exclude directories for Photos Library

Hi All,

I am trying to copy my photos from my Pictures directory to a remote. Unfortunately the Pictures folder also has the System photo library that I want to exclude from the backup. I have tried using --exclude-from but haven't been able to make it work...

I created a filter file with the following:

"Photos Library.photoslibrary/**"
"Photo Booth Library/**"

Then I use the --exclude-from flag to see if it works using this:

Pictures % rclone ls ./ --exclude-from filter

The list includes the Photos Library directory and all the files.

Interestingly, when I use --exclude it works!

Pictures % rclone ls ./ --exclude "Photos Library.photoslibrary/**"

I know I can use a double --exclude and call it a day but I like the clean approach of using a filter file in case I need to add more directories to exclude in future. Not sure why --exclude-from isn't working but --exclude is.

You missed using the template so it's a bit tough to figure out your setup.

What version are you running?
Can you share the debug output of the command with -vv on it?

Are those " in the file? If so remove them!

This worked! Thanks.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.