Unable to directly download or upload from folder via browser

What is the problem you are having with rclone?

I've set up rclone some time ago to automatically start at the system startup. I can't remember if it has always been like this, but now it seems I am unable to download files (seen with images, at the moment) directly to the folder the drive is mounted in. At the same time, trying to upload one via browser (FireFox) is not working and gets stuck seemingly forever.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 6.2.0-37-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.4
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Here's the command that runs at startup, taken from ps aux output:

/usr/bin/rclone mount --config=/home/slim71/.config/rclone/rclone.conf --allow-other --cache-tmp-upload-path=/tmp/rclone/upload --cache-chunk-path=/tmp/rclone/chunks --cache-workers=8 --cache-writes --cache-dir=/tmp/rclone/vfs --cache-db-path=/tmp/rclone/db --no-modtime --drive-use-trash --stats=0 --checkers=16 --bwlimit=40M --dir-cache-time=60m --vfs-cache-mode=full --cache-info-age=60m GDrive:/ /home/slim71/Documents/GDrive/

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = 
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

Unfortunately I don't know how to get the logs from an already running session during the operations I'm trying. I'm responsive though, so I can do it if instructed!
Hopefully this video will help in some way...

welcome to the forum,

yeah, that might explain these flags, which are for the deprecated cache remote.


--checkers=16 does nothing on a mount.

kill the mount, add something like --log-level=DEBUG --log-file=/path/to/rclone.log

fwiw, test on the command line using a small, text file, get that working first, then try other apps like web browser.
something like
cp /home/slim71/Documents/GDrive/test.txt ./
cp ./text.txt /home/slim71/Documents/GDrive

OK, I should have done everything.

I've deleted the parts you've highlighted (thanks for the notice!), so now the command I ran is

/usr/bin/rclone mount --config=/home/slim71/.config/rclone/rclone.conf --allow-other --cache-dir=/tmp/rclone/vfs --no-modtime --drive-use-trash --stats=0 --bwlimit=40M --dir-cache-time=60m --vfs-cache-mode=full --log-level=DEBUG --log-file=/home/slim71/rclone_logs/rclone.log GDrive:/ /home/slim71/Documents/GDrive/

First, I've tried the terminal commands as you suggested, to check that everything was working: all good.
Then I've retried basically the same stuff I've shown in the video, and I got the same result :frowning:

But at least the logfile should be useful! Here it is: rclone.log (540.2 KB)
I see some mode=-rw-r--r-- which might give an insight on the permission errors, but I could not figure out much more.
More or less, the timestamp at which I've tried the stuff in the video is 2023/12/08 18:56:41

Let me know if there's still something wrong or something else needed :slight_smile:

please make sure to delete the log file before running rclone, ok?
just post the log for the last run of rclone, ok?
else gets very confusing, very quick

delete log, run rclone, try operation in web browser, kill rclone, post full debug log

and to make testing easier and the logs easier to read, mount a subfolder on gdrive, something like
rclone mount GDrive:subfolder ....

very hard to view that video. please, create a small sized video, at most, one screen only.
make sure the text can be read clearly before posting.

sorry, night came where I live!
Here's a better video, or at least doing everything in a single screen seems better to me and what I'm doing is visible: rclone_issues-2023-12-09_11.05.44.mkv - Google Drive
Here's the log created during the video:
rclone.log (254.4 KB)

@asdffdsa did you check it out perhaps?

about your log, i took a quick look, did not see any issues.

i did a quick test, worked for me, drag/drop an image from rclone mountpoint to google.com.

And does it work when image file is not from mount but from your local filesystem?

@asdffdsa strange, I can't seem to make it work...

@kapitainsky yes, and that's the workaround I'm currently using in order to use stuff from the drive

BTW. I have tried it on macOS using Firefox. Works without any issues...

maybe try with simplified rclone mount command? e.g.:

/usr/bin/rclone mount --config=/home/slim71/.config/rclone/rclone.conf \
--allow-other \
--vfs-cache-mode=full \
GDrive:/ /home/slim71/Documents/GDrive/

You have a lot of flags which either do not make sense at all (--checkers=16), are deprecated (--cache-chunk-path..) or I am not sure what purpose they serve (--no-modtime). It is possible that such mix creates unexpected results.

Start with something simple.

I've tried again with only

/usr/bin/rclone mount \
--config=/home/slim71/.config/rclone/rclone.conf \
--allow-other \
--vfs-cache-mode=full \
--log-file=/home/slim71/rclone_logs/rclone.log \
GDrive:/Tesi/Media /home/slim71/Documents/GDrive/

but the result was the same... :man_shrugging:
rclone.log (83 Bytes)

I did find something else while trying to post this.
It seems that sometimes, when I try to upload something (now on Google or for example the log file above, so in this forum) to FireFox, the file is being "rejected".

To check this, I've launched FireFox from CLI and retried:

There's some kind of error related to the file descriptor! :astonished:
Didn't see anything when downloading, but this is a good start...

What's complicating things is that this does not seem to be related to rclone afterall, since it happened with the log file too (which is in another path). I'll try to see if I can figure something out for a ticket to the devs...

You're welcome for any input, but as I've said I don't think this is relevant to rclone (and indeed you seem not to be able to replicate it), so I'll wait a bit and close this.
Thanks! :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.