Unable to create a Box connection

What is the problem you are having with rclone?

Cannot connect to Box.

When running rclone config I am unable to get a box app or connection created.

I have tried two ways.

  1. creating with all defaults in the config process - this results in a web page message stating
Disabled by Administrator

This application cannot be used because it is not allowed by your Box administrator.

If you have any questions, please contact your administrator at support@domain.com 
  1. Creating an app, getting it approved and enabled by the Box administrator, and then entering the client_id and client_secret

This results in a web browser message

There seems to be a problem with this app.
Don't worry, your files are perfectly safe. Get in touch with Box support to get assistance with this app. We're here to help.

Error: redirect_uri_mismatch
 Show Error Details

I have attempted to add the to the CORS domains section of the app config, but that doesn't seem to change the redirect_uri issue.

Finally, when I use the developer token in access_token I can see my own files, but this of course does not require any browser windows to be opened to complete auth.

Other info:

  • Our organisational admin of Box reports there is no rclone app in the Box app centre that can be enabled.
  • 2fa is enabled.
  • Account is a Business Plus, I have no idea if that makes any difference!

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.0
- os/version: darwin 12.6 (64 bit)
- os/kernel: 21.6.0 (x86_64)
- os/type: darwin
- os/arch: amd64
- go/version: go1.19.2
- go/linking: dynamic
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config 

The rclone config contents with secrets removed.


A log from the command with the -vv flag

Scenario 1 (creating with all defaults) :
Paste log here

Scenario 2 (using established app and client_id):
Paste log here

Thanks in advance!

This needs to go as the redirect_uri under the Configuration tab

Thanks, I created the initial app using Enterprise, created a new one with User based permissions and we are off to the races. New to both of these tools, so appreciate the hint here!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.