UBUNTU: rclone mounts but doesn't give the prompt back

What is the problem you are having with rclone?

I run this command to mount a Google drive folder:

rclone mount drive:folder /mount_point --allow-other --allow-non-empty --log-file ~/rclone.log

After a few minutes, I can see the drive is mounted, however, It neither returns the prompt nor writes on ~/rclone.log. If I press CTRL-C, i get the prompt back, the drive is unmounted and this entry in ~/rclone.log:
2023/03/02 10:55:09 ERROR : /mount_point: Unmounted rclone mount

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-204-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount googledrive:folder /mount_point --allow-other --allow-non-empty --log-file ~/rclone.log

The rclone config contents with secrets removed.

type = drive
scope = drive
token = 

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

that is expected behavior. if you want to access the files in the mount, rclone mount command has to be running.
can work around that with --daemon, cron, systemd, automount, tmux/screen

try --log-level=DEBUG

unless you are 1000% sure, i would remove that flag.

Hello and thank you, what a relief if that's normal behaviour.

I've tried to make the remote mount automatic at boot time, inserting this line in the root cron:

@reboot script.sh

rclone mount googledrive:folder /mount_point --allow-other --allow-non-empty

It didn't work :frowning:

What am I doing wrong? Do you have a better idea?

Again, thank you

  1. make sure script.sh works from the terminal.
  2. as i mentioned up above, --allow-non-empty - what reason is there to use that most troublesome flag?
  3. as i mentioned up above, use --log-level=DEBUG
  4. why did you remove --log-file from script.sh? must use a log file.
  5. use full path for everything
  6. hardcode the full path of the config file using --config
  1. Yes, it works from the terminal
  2. I removed the flag
  3. I am using --log-level=DEBUG
  4. I didn't remove, just didnt write it once again
  5. I changed the script to use the full path
  6. Didn´t do that because I don´t know the syntax

So, script.sh:
rclone mount googledrive:folder /mount_point --allow-other --daemon --log-file full_path/rclone.log --log-level=DEBUG

Rebooted the system and it didn´t mount googledrive, in spite of keeping @reboot script.sh in the root cron :frowning:

  1. must use full path for everything, including the location of /fullpath/to/rclone
  2. can check the rclone docs, --config=/fullpath/to/rclone.conf
    if that does not solve the issue, then post the full debug log.

fwiw, with script.sh, to keep the log file small.

  1. delete the log file
  2. and then run rclone

Hey there, thanks a lot for your support, rclone now is working like a charm ! :clap: :clap: :pray:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.