Two different users watching the same movie

What is the problem you are having with rclone?

When two people attempt to watch the same movie or TV show on plex they will not stream and just buffer ever couple seconds. If someone is far along in the video, the file will stop downloading and begin to buffer when some else starts to watch it.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

usr/sbin/rclone mount -v --allow-other --stats-log-level=NOTICE --log-file=/home/plex/rclone/rclone.log --stats=1m --fast-list --vfs-read-chunk-size=32m --vfs-read-chunk-size-limit=512m --buffer-size=2g --dir-cache-time=1m plex:Plex /home/user/Mount --uid 1000 --gid 1000 &

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

No log is attached.

does nothing on a mount and can be removed.

Why is that 1 minute?

Did you change these for a reason and not use the defaults?

What was the reason for this? It'll make rclone read 2G of the file.

Can you recreate the issue and include a debug log.

Thanks for your quick response. [quote="Animosity022, post:2, topic:13473"]
Why is that 1 minute?
I’m not sure. I’ve always had this set and I may have carried this command over from when I was using a Cache backend.

I have been using this and always found it to work well for speed of playback. Probably picked it up from someone else’s settings.

I have a decent amount of ram so I always did this to have a good buffer

I will recreate this and post the logs. It’s easy to recreate because I am just unable to play the same Video file at the same time as someone else.

I have had this set up for a while and it’s always been an issue even on two different builds. Wasn’t sure if it was a limitation of rclone or something else is going on.

It would be bad with the cache backned too. You want that number something large like 100+ hours as it's wasted API calls.

I'd remove both of those and starts with the defaults.

Making it 32M increases API calls too and the buffer might be hindering as well as you have 2 files open both asking for 2G of the file so you might be throttling something along the way. Hard to tell to you share the logs.

Are both people transcoding / direct playing?

I’ve tried variations of both. Both transcoding and both direct play and a combo of both.

So I restarted the server this morning and tried the settings you recommended. I tested watching a movie my kids were watching (different usernames) and it would not start and caused their video to buffer shortly after. The log file is huge and I am not sure how you want me to post it. Funny thing is now I'm trying to do it again so I can mark the exact time and is now working fine.

You can use pastebin / google drive link / any way you want to share a file.!AuZ6p9nV33VmymC1sGuEAPcjv4Wq?e=we7l6H

That seems to be a partial log? Any chance on the full thing?

Yeah I trimed it for size. I'll share the whole thing.

Thanks for your help. Here is the full log.!AuZ6p9nV33VmymJm1h_2se5Zkmb3?e=fx6hPW
The issue started around 10:00:58

First bit is your DNS is having an issue:

 tcp: lookup on server misbehaving

What's your setup as all the file names are encrypted? Is something else decrypting it?

I use encfs to decrypt. So google is mounted with rclone to local folder, then that folder is decrypted to a read only folder. I use mergerfs for reads and writes to media folder. I believe I got that part from one of your posts.

Hmm, that would make it more interesting as that's another layer on top :frowning:

I guess it might be related to encfs as it seems to open and close a lot so not sure.

grep Flush Rclone\ 2.txt | wc -l

It's hard to tell what you are playing though with encfs in the middle.

I use encryption with rclone and I can definitely stream and get a good rate with the same file.

Ok. Thanks for your help. Unfortunately I'm stuck with encfs because of my library size. It would be impossible to switch to rclone's encryption now. I originally used something else prior to rclone.

I'm not sure with encfs as what you can setup to perhaps make it keep things open? You could try to use the cache backend and see if that helps too.

I rebooted and added a --nocache option to encfs to see if that helps. Funny thing is after a reboot there are no issues. I can play multiple of the same file. After its up for a bit is where I start having the issue.