Trying utilize docker for the first time. Having some issues with an rclone mount. User_Allow_other error. /etc/fuse.conf has been updated to allow

I am stuck rebuilding my plex server from the ground up after a OS corruption. I have backups of all the necessary things like databases but I figured I would give docker a try because I liked the ability to do updates and switch machines and it all be there from a config file. Anyway. I am setting up my first docker-compose.yml and I am trying to configure rclone. My docker-compose is as follows.

version: '3.8'
                image: rclone/rclone:latest
                user: 1000:1000
                network_mode: host
                restart: always
                container_name: rclone
                  - SYS_ADMIN
                  - /dev/fuse
                  - apparmor:unconfined
                  - ~/utilities/rclone:/config/rclone
                  - ~/utilities/rclone/data:/data:shared
                  - ~/utilities/rclone/logs:/logs
                  - ~/utilities/mounts/plexcache:/plexcache:shared
                  - /etc/passwd:/etc/passwd:ro
                  - /etc/group:/etc/group:ro
                  - /etc/fuse:/etc/fuse
                command: "mount plexcache: /plexcache --allow-other --dir-cache-time 72h --buffer-size 1G --drive-chunk-size 32M --timeout 1h --rc --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit off --umask 002 --bind --log-level DEBUG --log-file /logs/rclone.log"

Within the rclone log I keep seeing this:

    2020/05/15 04:07:39 NOTICE: Serving remote control on
    2020/05/15 04:07:39 DEBUG : Using config file from "/config/rclone/rclone.conf"
    2020/05/15 04:07:40 DEBUG : Encrypted drive 'plexcache:': Mounting on "/plexcache"
    2020/05/15 04:07:40 mount helper error: fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
    2020/05/15 04:07:40 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

my fuse.conf is set correctly though with the user_allow_other undocumented. Any ideas? Thanks!

It is the fuse.conf in the container which needs to be set!

I can reproduce this

docker run --rm     --volume ~/.config/rclone:/config/rclone     --volume /mnt/tmp:/data/mount:shared     --user $(id -u):$(id -g)     --volume /etc/passwd:/etc/passwd:ro --volume /etc/group:/etc/group:ro     --device /dev/fuse --cap-add SYS_ADMIN --security-opt apparmor:unconfined     rclone/rclone     mount /bin /data/mount --allow-other

This probably needs to be done in rclone's Docker file


echo "user_allow_other" >> /etc/fuse.conf

is enough to fix it.

Fancy sending a PR to fix rclone's Docker file?

Thank you Nick, Any idea of how to get the echo command within the container before I run the mount command?

Mounting your system /etc/fuse.conf into the container should do it.

Any reason you are mounting /etc/fuse? I believe that should be /etc/fuse.conf instead, which solves your problem.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.