Trying to use copyurl to download from authenticated URL

What is the problem you are having with rclone?

Trying to use copyurl since this is the best logical command and im getting the unauthorized error. I need to sign into the website with my username and pw but not sure how to use with rclone. tried signing in with chrom before running the command and didnt work

What is your rclone version (output from rclone version)

rclone v1.52.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/arch: linux/arm

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copyurl local:/disks/HDD/-PiDownloaded/RcloneDownloaded --error-on-no-transfer --transfers 1 --progress 

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret = 
scope = drive
token = {"access_token":"ya29.a0AfH6SMC8eChFyTyNGxOpFXrxWHIdgS6-yPnMt2eJOVVMlrVwSn8WS4_HXwImv_QkT60BaFkVXfd4ywq4wk9Iirxqn7CwCzhSDSpkqOMdxRTVpaTCGMfszVliyzUnH76V1TQp61BlohFIjcsEMsZpY4zGCZDOKzSTuQRiCg","token_type":"Bearer","refresh_token":"1//06NuNMJSbFtdfCgYIARAAGAYSNwF-L9Ir0VVRZQ5JfAMZGG3zeFo49ibzGwghLl98QOKEuYM-UMCTYEFKxYI5oXL2BYws5YesySI","expiry":"2020-09-07T22:47:01.35919393-07:00"}
team_drive = 0AGnvsIcTBKZJUk9PVA

type = local

A log from the command with the -vv flag

I believe you can just embed as part of the url.

rclone copyurl local:/disks/HDD/-PiDownloaded/RcloneDownloaded --error-on-no-transfer --transfers 1 --progress

I tried this as i seen another user mention this. It unfortunately does not work for me. I still get the 401 unauthorized error

I did just test it and it does infact work for normal auths. I'd guess the website is doing something different.

If the site uses cookies, you can probably do this:


and set the cookies. or use --use-cookies

Will keep this is mind. Im trying something else with the first mentioned command and now im getting "local:/disks/HDD/-PiDownloaded/RcloneDownloaded/" is a directory as an error. my full command is

rclone copyurl local:/disks/HDD/-PiDownloaded/RcloneDownloaded/ --error-on-no-transfer --transfers 1 --progress 

Wouldnt the syntax make sense though?

copyurl copies a file and not a folder though.

You can use the http remote though...

rclone copy :http: --http-url local:/disks/HDD/-PiDownloaded/RcloneDownloaded/

using this give this:
Failed to copy: error listing "": directory not found

Then the site isn't compatible. We can't see the site so it's hard to tell you.

Thanks for trying. Ill try figuring something out. I appreciate your time!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.