Trying to backup a google drive ends up filling my disk with recursive stuff

First of all, thanks for this wonderful project :tada:

What is the problem you are having with rclone?

I want to do regular update of a google drive (for an association).

But the download is filling my 2T volume (while it should be about 500Mb).

It seems to have problem with directories with shortcuts in them referring to a directory

eg. I have "Community Management :raising_hand_woman:" wich as just inside a shortcut named "Community Management" referring to itself !

Yes it's a bit messy, but it seems to make rclone crazy and trying to traverse this shortcut indefinitely.

Advertized shortcut behaviour is not clear to me.

  • When downloading the contents of the linked folder and sub contents are downloaded

I tried to turned copy_shortcut_content to false.

I tried with and without fast-list.

Run the command 'rclone version' and share the full output of the command.

rclone --version
rclone v1.65.0
- os/version: debian 11.8 (64 bit)
- os/kernel: 5.4.203-1-pve (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.4
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync off-gdrive: /mnt/gdrive-backup/Open-Food-Facts/

Please run 'rclone config redacted' and share the full output. If you get

type = drive
client_id = XXX
client_secret = XXX
scope = drive.readonly
root_folder_id = 
token = XXX
team_drive = XXX
copy_shortcut_content = 0
buffer-size = 256M
fast-list = true
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

Sorry but it's a far too long log… and I don't want to show our file structure, so I only put selected bits:

24/02/13 16:19:15 DEBUG : Community Management πŸ™‹β€β™€οΈ/Community Management/Community Management/Community Management/Community Management/Community Management/JournΓ©es OFF 2022/Capsule interviews /Ambiance video clips/C0019.MP4: Need to transfer - File not found at Destination

welcome to the forum,

just some basic comments

that cannot go into the config file, needs to be flag on the command line.

that cannot go into the config file, needs to be a flag on the command line.
and based on forum posts, that flag is not often used and really does not do much.

flag syntax in the config file, use _, not -

not too familair with shortcuts, but might try --drive-skip-shortcuts

Hi @asdffdsa , thank you so much for your answer.

Indeed I saw my error on the flags and put them again with "_". (but I don't know how to remove those bad options :grimacing: )

And in fact skip_shortcut seems to be the right bet. It seems to work.

I will do a PR to propose to add some kind of indication on the help page !

Here is the PR: drive: add an indication in case of recursive shortcuts in documentation by alexgarel Β· Pull Request #7633 Β· rclone/rclone Β· GitHub

fast-list and buffer-size, those flags are global flags, do nothing in config file, only work on command line and/or environment variables.
the config file is plain text, so open it with a text editor and remove them.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.