Trouble installing rclone on Ubuntu

After installing snapd on Ubuntu, I entered

sudo snap install rclone --classic

The download/install seemed to go without incident, but when I got the prompt and typed ‘rclone’ it said “command not found”. When I ran the above command again it said “rclone already installed.”

It’s not in /usr/bin, /usr/sbin, nor anywhere on /usr/local, nor in my personal directory.

I also tried downloading the AMD zip file, which gives me a failure message.

I have no idea where it is…

We’ve dediced that the whole snap thing isn’t a good way of distributing rclone and removed it for 1.38 :frowning: I suggest you follow installing from a precompiled binary or alternatively use the rclone package in the ubuntu repo which is 1.35 at the moment.

Thanks for your comments.

When I run

curl -O

I get an error message that the zip file is corrupted or incomplete. I’ve tried this several times.

I also can’t find an Ubuntu repository for rclone. I use Synaptic Package Manager, and it can’t find it.

I was running Ubuntu 14.0.4 LTS, upgraded today to 16.0.4 LTS - same behaviors.

Stuck at this point…

Seems to work here but i use the beta.

100%[======================================>] 5,621,327 5.10MB/s in 1.1s

2017-09-18 13:27:42 (5.10 MB/s) - ‘/tmp/rclone/’ saved [5621327/5621327]

  • unzip -j /tmp/rclone/ -d /tmp/rclone/ ‘*/rclone’
    Archive: /tmp/rclone/
    inflating: /tmp/rclone/rclone
  • [[ -f /usr/sbin/rclone ]]
    ++ awk ‘{print $2}’
    ++ /usr/sbin/rclone -V
  • CURRVER=‘v1.37-066-g40f24e0eβ
  • echo EXISTING: /usr/sbin/rclone.v1.37-066-g40f24e0eβ os/arch: go
    EXISTING: /usr/sbin/rclone.v1.37-066-g40f24e0eβ os/arch: go
  • sudo mv /usr/sbin/rclone /usr/sbin/rclone.v1.37-066-g40f24e0eβ os/arch: go
    mv: target ‘go’ is not a directory
  • sudo cp /tmp/rclone/rclone /usr/sbin/rclone
    cp: cannot create regular file ‘/usr/sbin/rclone’: Text file busy
  • sudo chmod 755 /usr/sbin/rclone
    ++ /usr/sbin/rclone -V
    ++ awk ‘{print $2}’
  • NEWER=‘v1.37-066-g40f24e0eβ
  • echo NEW VRSN: /usr/sbin/rclone : v1.37-066-g40f24e0eβ os/arch: go
    NEW VRSN: /usr/sbin/rclone : v1.37-066-g40f24e0eβ os/arch: go

current one works too.

HS -> wget
–2017-09-18 13:29:36--
Resolving (…, 2a02:24e0:8:61f9::1
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 5352167 (5.1M) [application/zip]
Saving to: ‘’

100%[======================================>] 5,352,167 4.98MB/s in 1.0s

2017-09-18 13:29:38 (4.98 MB/s) - ‘’ saved [5352167/5352167]

✓ robert [/data/bin] $
HS -> unzip
creating: rclone-v1.37-linux-amd64/
inflating: rclone-v1.37-linux-amd64/README.html
inflating: rclone-v1.37-linux-amd64/rclone
inflating: rclone-v1.37-linux-amd64/rclone.1
inflating: rclone-v1.37-linux-amd64/README.txt
✓ robert [/data/bin] $
HS -> rclone-v1.37-linux-amd64/rclone --version
rclone v1.37

Many thanks! wget worked, curl did not.