Trailing characters with --stats-one-line -P --stats

#1

I use rclone a lot and it’s the first time I have trailing characters when I use the flags:

--stats-one-line -P --stats

The 4) that is highlighted on the image remains even after the stats get updated every couple of seconds.

#2

I am still on the same upload (still on the same cmd windows) and now I have 3 trailing characters, not two.

#3

What’s the full command you are running? What rclone version are you using?

I try to do that and get:

[felix@gemini data]$ rclone copy 1G.out GD: --stats-one-line -P
152M / 1024.000 MBytes, 15%, 18.950 MBytes/s, ETA 46s^C
[felix@gemini data]$ rclone copy 1G.out GD: --stats-one-line -P --stats
Error: flag needs an argument: --stats
Usage:
  rclone copy source:path dest:path [flags]

Flags:
      --create-empty-src-dirs   Create empty source dirs on destination after copy
  -h, --help                    help for copy

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.

2019/04/16 09:51:15 Fatal error: flag needs an argument: --stats
[felix@gemini data]$ rclone version
rclone v1.47.0
- os/arch: linux/amd64
- go version: go1.12.4
#4

Here is my command:
rclone sync “local folder” “remote name”:“remote folder” --log-file “path to log” --log-level INFO --delete-after --copy-links --stats-one-line -P --stats 5s

you need to replace local folder, remote name, remote folder and path to log

I don’t think it matters but I am syncing on a google drive account.

Notice, that this is the first time that I see this bug and I do a lot of sync with rclone.

I am still on the same upload and now I only have 2 trailing characters

#5

Sorry, I forgot my rclone version:

rclone --version returns this:

rclone v1.43.1
- os/arch: windows/amd64
- go version: go1.11

I have just updated to version 1.47, I will let you know if I still see this bug.

Yes, I still get the bug with 1.47. I was able to witness it this time.
When I started the rclone command, the ETA was something 11h11m11s but a couple of second after it became 1h1h11s and because the number of characters in this second ETA is less (7 vs 9 for the first ETA), then I get the trailing characters.

#6

I’d open an issue on the github and include your OS version.

I ran a few tests myself and couldn’t reproduce it unfortunately so if you can include more details that may help narrow it down as well.

#7

Do you have any special characters in your files? Chinese or japanese?

The Windows terminal is a bit of a mess when it comes to those and CMD and powershell behave differently, so it might be worth trying the other one of those.

#8

No I don’t have special characters like Chinese and Japanese, but I do have ~ and %.

I start my rclone command in 2 different ways:

One way is to double click on a cmd file with this in it (this script get the script filename and create a path for the log file in another folder):

@echo off

echo start CMD

set datetime=%DATE% %TIME%

REM get filename of cmd

set filename=%~n0

set new_filename=%filename:Real =%

 REM get grandparent folder

SET parent=%~dp0

FOR %%a IN ("%parent:~0,-1%") DO SET grandparent_folder=%%~dpa

REM create log filename from new_filename 

set grandparent_folder

if not exist "%grandparent_folder%log" mkdir "%grandparent_folder%log"

set logpath= "%grandparent_folder%log\%new_filename%.log

@echo on

rclone sync “local folder” “remote name”:“remote folder” --log-file %logpath%" --log-level INFO --delete-after --copy-links --stats-one-line -P --stats 5s

python "format_log_rclone.py" "%logpath%" "%datetime%" 

Note that it is normal that there is only a single " after %logpath% (and none before).

The second way is to start a python script with a GUI that let me choose with cmd I want (I have several cmd like the one above for different remotes/Google drive). The cmd is called with subprocess.call([cmd_path]).

I have the trailing characters for both even though the first one is running in a cmd console and the second one in a python console.

Note that the trailing characters don’t bother me, but it may bother or confuse new users.

I am trying in powershell and will let you know

#9

Well I didn’t take that long… I still get the trailing characters in Powershell.

#10

Hmm… Which version of Windows are you using?

I wonder if this is to do with the config password… Can you try removing the config password and see if that helps? The config password turns off echoing which I suppose could mess up the terminal somehow.

#11

I try without the password, I still got the bug. I also recreated a brand new config file, with a new remote on a drop box account this time (instead of Google drive) and… same bug.

Now that you mention my version of Windows… I updated a couple of days ago to Windows 10 version 1809 build 17763.437 (I was before on Windows 10 1803). This may be the cause why I never got the bug before and wrote in my first post that “it’s the first time” thinking I may not get the bug any time some. But each time after I tried I got it in less than 30 secondes.

#12

Thanks for doing that testing.

Can you please make a new issue on github about this. Please put a link to this thread and relevant info in there - thank you.

#13

You can find the new issue here. Sorry for the delay!

1 Like