TinyMediaManager, RClone, EncFS and a little mount Problem?

Hey all,

first I have to say you are all great. I Love this Forum and RClone. Thanks for this :slight_smile:

As Many of you I moved my Movies and Series from my NAS to GDrive and use Rclone to mount a crypted EncFS Folder. My Player is Plex.

It all works fine but I have much work to scrape them because I forgot to Order and name them. Now I tried to use TinyMediaManager to rename and order them.

I use WinSSFS to mount the decrypted Folder to Windows as a Drive. Works. Create Folders, Files and rename works too. But if I try TMM to rename the mkv-files nothing happens. Maybe someone of you know this issue and can help me. These are my mount commands:

rclone mount --allow-other --vfs-cache-mode writes gdrive:/ /home/user/mnt/gdrive/ --dir-cache-time 25h --cache-info-age=30h --cache-chunk-size=50M --cache-workers=5 --cache-tmp-wait-time 60m --buffer-size 512M --cache-db-path=/data/rclone_cache --cache-chunk-path /data/rclone_chunk --cache-tmp-upload-path /data/rclone_upload --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 5G

encfs -S -o allow_other /home/user/mnt/gdrive/files /home/user/mnt/plexfiles

thanks for reading,

buffer-size and cache really don’t go do together. If you want to use cache, make the buffer-size 0m as that makes cache slower.

the vfs-read-chunk and limit also do nothing if you aren’t using cache. vfs tends to be faster as I use that and do not use cache. I’d pick one or other and use that.

What are the logs saying when you try to rename something? Can you share those?

Thank you for the Answer Animosity,
Now I tried your advice and used only vfs. It doesn’t work on Windows. So I tried it on a Ubuntu VM. Result: Renaming and Moving works but it hung up after a view Episodes. Can it be that the cache/vfs is too slow ?

This is the Mount:
rclone mount --allow-other --vfs-cache-mode writes gdrive: ~/mnt/gdrive/ --dir-cache-time 25h --buffer-size 0M --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 5G

Logging says no errors. Tried to post it but its too much in debug logging and info or error says nothing.

Not sure what doesn’t work on Windows since you didn’t share any logs as I’ve read a number of posts of folks using it on Windows.

If you are using the cache backend, you’d turn off buffer-size and make it 0M. If you are not using the cache-backend, you do want some buffer-size depending on the memory in your system.

You can use pastebin or something along those lines to post the logs as without them, we can’t really see/figure out what’s going on.

Not sure what ‘view episode’ is either. Does that mean playing it?