Throttling but I've not figured it out

Hi ppl,

Sorry if this another repeating thread but I've read several posts about Google Drive throttling and I can't figure it out, tried all suggestions I suspect that could be wrong.

I am mounting it and using hb (hashbackup) to save my backups there, but no matter what settings I choose, I get throttled to 166KB/s after 280-300GB uploaded.

I have also checked google API details and there's no limit or errors being hit. Also tried rclone with -vvv and there's no error being logged.

I am using my own client ID.


rclone v1.57.0
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: 5.13.0-27-lowlatency (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

My latest command-line attempt is:
(removing --checkers or --tpslimit does not solve the problem anyway)

rclone mount \
   --user-agent 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.107 Safari/537.36 Edg/92.0.902.55' \
   --checkers=12 \
   --transfers=8 \
   --multi-thread-cutoff=2M \
   --multi-thread-streams=8 \
   --fast-list \
   --cache-dir /mnt/cache/rclone-cache \
   --stats 1m \
   --drive-chunk-size 8M \
   --vfs-read-chunk-size 8M \
   --vfs-read-chunk-size-limit off \
   --vfs-cache-mode full \
   --vfs-cache-poll-interval 20m \
   --vfs-cache-max-age 24h \
   --attr-timeout 24h \
   --dir-cache-time 24h \
   --attr-timeout 24h \
   --bwlimit 8650k \
   --rc \
   --rc-web-gui \
   --rc-web-gui-update \
   --rc-user admin \
   --rc-pass admin \
   --vfs-cache-max-size 100G \
   --retries 34560 \
   --retries-sleep 5s \
   --tpslimit 5 \
   cr1:/ ~/remote/cr1 \

That's the most baffling command.

What's that there for?

Is that there for a reason?

Does nothing on a mount.

Best to make a mount and start with the defaults unless you have a reason for changing it.

Can you share a debug log as we have no idea what error you are hitting since there isn't a log?

I've removed all the options you flagged but I'm still getting throttled. As far as I remember the debug log does not show anything valuable, but I will try again and save a new debug log.


The read chunk is because I can't get full speed with only one connection/read. The other ones I really don't know exactly why they're there, I tried so many options.

rclone --fast-list --allow-other --dir-cache-time=24h --vfs-read-chunk-size=32M --vfs-read-chunk-size-limit=2G --buffer-size=1G --drive-chunk-size=512M --vfs-cache-mode=full --log-level DEBUG --bwlimit 8650k:off --stats 1m --cache-dir /mnt/cache/rclone-cache mount cr1:/ ~/remote/cr1

Probably won't get throttled but I can't get past 9-11Mbit/s upload speed with this. (I'm on 1G/500M fiber)

I'll try again and save a debug log.

Need a full log as that's a tiny snippet and I can't see much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.