Terrible upload speeds

What is the problem you are having with rclone?

I'm new to rclone (currently evaluating whether I can replace my NAS drives), and I'm getting atrocious upload speeds (~100 kBytes/s). I've read numerous similar posts on here, and have set-up my own Client ID/Secret but the issue still remains.

What is your rclone version (output from rclone version)

rclone v1.53.1
- os/arch: linux/amd64
- go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04, 64 bit.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone copy -vv "/home/ubuntu/Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv" "google-drive:Movies/Knives Out (2019)" --progress --drive-chunk-size=64M

The rclone config contents with secrets removed.

[google-drive]
type = drive
client_id = [REMOVED]
client_secret = [REMOVED]
scope = drive
token = {"access_token":"[REMOVED]","token_type":"Bearer","refresh_token":"[REMOVED]","expiry":"2020-10-05T09:22:36.113321434Z"}

A log from the command with the -vv flag

ubuntu@rclone:~$ /usr/bin/rclone copy -vv "/home/ubuntu/Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv" "google-drive:Movies/Knives Out (2019)" --progress --drive-chunk-size=64M
2020/10/05 08:34:43 DEBUG : rclone: Version "v1.53.1" starting with parameters ["/usr/bin/rclone" "copy" "-vv" "/home/ubuntu/Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv" "google-drive:Movies/Knives Out (2019)" "--progress" "--drive-chunk-size=64M"]
2020/10/05 08:34:43 DEBUG : Creating backend with remote "/home/ubuntu/Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv"
2020/10/05 08:34:43 DEBUG : Using config file from "/home/ubuntu/.config/rclone/rclone.conf"
2020/10/05 08:34:43 DEBUG : fs cache: adding new entry for parent of "/home/ubuntu/Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv", "/home/ubuntu"
2020/10/05 08:34:43 DEBUG : Creating backend with remote "google-drive:Movies/Knives Out (2019)"
2020/10/05 08:34:43 DEBUG : Google drive root 'Movies/Knives Out (2019)': root_folder_id = "0AENParz3mJn2Uk9PVA" - save this in the config to speed up startup
2020-10-05 08:34:44 DEBUG : Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv: Need to transfer - File not found at Destination
2020-10-05 08:34:45 DEBUG : Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv: Sending chunk 0 length 67108864
Transferred:   	    1.059M / 2.318 GBytes, 0%, 105.640 kBytes/s, ETA 6h23m15s
Transferred:            0 / 1, 0%
Elapsed time:        11.8s
Transferring:
 *   Knives.Out.2019.1080p.BluRay.x264-YOL0W.mkv:  0% /2.318G, 98.796k/s, 6h49m47s

Would appreciate any help.

What's your Internet rated at?
Can you see API hits on the Admin Console for Google with the new client/secret you setup?

You can increase this as well to something bigger depending on your memory as I use 1G myself.

What's your Internet rated at?

A speedtest is giving me 236 Down and ~3 Up...

image

You can increase this as well to something bigger depending on your memory as I use 1G myself.

Increasing this doesn't seem to make any difference, I did play around with different values. Increasing it to 1G gives very similar results at ~100 kBytes/s so I assume the bottleneck is somewhere else.

I couldn't put too images in the same post :man_shrugging:

Can you see API hits on the Admin Console for Google with the new client/secret you setup?

Yeah....

image

At 3Mb/s, rclone is reporting a little less than 1Mb/s as it reports in "bytes" not "bits". Are you using upload for anything else as that's a tiny pipe.

At 3Mb/s, rclone is reporting a little less than 1Mb/s as it reports in "bytes" not "bits".

Ah, I missed that it was reporting in bytes. I am using upload for other things, as I WFH so that probably explains it.

Guess that's my answer :slight_smile:

Thank you.

Enable TCP BBR to improve network speed on Linux

This DRAMATICALLY increased my upload speed. I went from 15 MB to 60+ MB on a 100 MB upload line.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.