Terrible Mount Speeds

What is the problem you are having with rclone?

Hello! I'm getting terrible speeds (130 - 150 KiB/s) on rclone mount while the speeds max out with rclone copy. I'm on a gigabit connection.

What is your rclone version (output from rclone version)

rclone v1.50.2

  • os/arch: linux/amd64
  • go version: go1.13.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

I was able to reproduce this issue on two machines running NixOS 19.09 and one machine running Arch Linux.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

copy: rclone copy remote:src /local/path -v --stats 1s
mount: rclone mount remote: /local/path --allow-other --buffer-size 1G --dir-cache-time 1000h --umask 002

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

rclone DEBUG log while mounting with the aforementioned flags and copying using rsync --info=progress2 Doctor.Who.2005.Last.Christmas.1080i.BluRay.REMUX.AVC.DTS-HD.MA.5.1-ROYALTY.mkv ~/

1 Like

problem was: Update on Linux kernel 5.4 and rclone mount issue

fixed by downgrading to LTS

Try using the latest rclone beta. It fixed this fuse problem with 5.4 kernels for me.

I don't have anything meaningful to add other than that I, too, was experiencing crazy mount issues and updating to rclone beta fixed it. Same root cause.

2 Likes