Systemd mount on synology DSM 7.1.1 fails

What is the problem you are having with rclone?

on Synology DSM 7.1.1-42962 Update 1, an rclone systemd mount unit fails due to an invalid short "no-mtab" flag.

Executing the same mount command systemd is trying to do WITHOUT the no-mtab "-n" flag works fine. I'm guessing there's a collision with rclone's own "-n" short flag for dry-run.

Testing with a simple bind mount (which mounted successfully), the ExecMount in status showed it also including the -n flag, so it may be automatically added by DSM's mount manager? I don't see a way to tell it to NOT do that.

Run the command 'rclone version' and share the full output of the command.

# uname -a
Linux forest 4.4.180+ #42962 SMP Sat Sep 3 22:22:16 CST 2022 x86_64 GNU/Linux synology_broadwellnk_3622xs+
# rclone version
rclone v1.60.0
- os/version: unknown
- os/kernel: 4.4.180+ (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

[Unit]
Description=Rclone Gsuite Mount
Wants=network-online.target syno-share.target pkg-volume.target syno-space.target syno-volume.target

[Mount]
Type=rclone
What="gsuite-crypt:"
Where=/mnt/gsuite_crypt2
Options=rw,allow_other,config=/var/services/homes/vena/.config/rclone/rclone.conf,uid=1026,gid=100,dir_perms=775,file_perms=664,log_level=DEBUG,log_file=/var/log/rclone/systemd_test.log

The rclone config contents with secrets removed.

[gsuite]
type = drive
client_id = 
client_secret = 
scope = drive.file
root_folder_id = 
token = 
team_drive = 
chunk_size = 8M
transfers = 2
checkers = 4
tpslimit = 10
bwlimit = 8M:off
pacer_burst = 200
pacer_min_sleep = 20ms
chunk_total_size = 8G
chunk_no_memory = false
workers = 12

[gsuite-crypt]
type = crypt
remote = gsuite:/crypt
password = 
password2 = 
bwlimit = off:off
pacer_burst = 200
pacer_min_sleep = 20ms
chunk_total_size = 8G
chunk_size = 8M
chunk_no_memory = false
workers = 12

A log from the command with the -vv flag

nothing is sent to the log_file in the mount options when this error occurs.

‚óŹ mnt-gsuite_crypt2.mount - Rclone Gsuite Mount
   Loaded: loaded (/var/services/homes/vena/rclone/mnt-gsuite_crypt2.mount; linked; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2022-10-24 17:12:00 EDT; 2s ago
    Where: /mnt/gsuite_crypt2
     What: \"gsuite-crypt:\"
  Process: 27359 ExecMount=/bin/mount "gsuite-crypt:" /mnt/gsuite_crypt2 -n -t rclone -o rw,allow_other,config=/var/services/homes/vena/.config/rclone/rclone.conf,uid=1026,gid=100,dir_perms=775,file_perms=664,log_level=DEBUG,log_file=/var/log/rclone/systemd_test.log (code=exited, status=1/FAILURE)

Oct 24 17:12:00 forest systemd[1]: Mounting Rclone Gsuite Mount...
Oct 24 17:12:00 forest mount[27359]: 2022/10/24 17:12:00 Failed to parse command line: flag "-n" is not supported in mount mode
Oct 24 17:12:00 forest systemd[1]: mnt-gsuite_crypt2.mount mount process exited, code=exited status=1
Oct 24 17:12:00 forest systemd[1]: Failed to mount Rclone Gsuite Mount.
Oct 24 17:12:00 forest systemd[1]: Unit mnt-gsuite_crypt2.mount entered failed state.

note, this happened on a previous version as well, though I updated while troubleshooting this and do not recall what version that was. just may be safe to say this wasn't introduced in 1.60.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.