Synology rclone Issues


Information to understand my post:
GDrive is a remote for my Google TeamDrive.
GEncrypted is a "crypt" remote for GDrive where filenames and directories are encrypted with the same key for the VPS and Synology NAS.
These two remotes are created equally on the VPS and Synology Nas.

I successfully mounted a Google Drive on my Ubuntu VPS with "crypt". The command I use is:

rclone mount GEncrypted: /GTeamDrive --vfs-cache-mode full --allow-non-empty --allow-other --vfs-cache-max-age 10m

It works really well. No problem so far. However, I also want to mount my Google TeamDrive with crypt on my Synology NAS. Thus, I tried to run this command:

rclone mount GEncrypted: /volume1/GTeamDrive/Test1 --vfs-cache-mode writes --allow-non-empty --allow-other

This sadly do not work. I can see the files and open the encrypted files inside my Google TeamDrive. However, I cannot copy files into the mounted folder. Here is what happens when I try to copy a random pdf to the mounted drive:

2019/05/31 20:10:09 ERROR : New folder/pdf (2).pdf(0xc0000ac6c0): failed to find cache file: object not found
2019/05/31 20:10:09 ERROR : New folder/pdf (2).pdf(0xc0000ac6c0): RWFileHandle.Release error: failed to find cache file: object not found

I tried many things including --vfs-cache-mode full (with this I cannot see the files nor folder inside my TeamDrive). Please let me know if you have any clues on how I can fix this problem.


I would mention that I tend to use rclone copy to transfer stuff to my gDrive rather than copying direct to the mount. But a couple of questions.

How did you get the fuse libraries installed on your nas?

How are you trying to copy the files into your mount?

I have an encrypted mount on my nas, and I just tried a few different ways of copying a file.

Using the File Manager in the DSM, that failed.

If I use ssh to connect my nas and copy a file from my nas to my gDrive using cp, then that worked.

I also connected to my nas from my iMac then browsed to the mounted folder and was able to copy a file from my iMac in to the Mounted drive.

In my mount settings my vfs-cache-mode is this:
--vfs-cache-mode minimal

(and I have the encrypted gDrive mounted on my dedicated server and can see the files that I copied to the drive on my nas in the mount on the dedicated server)


Thanks for helping me.

I actually am not sure if I installed FUSE or not and if yes how. It was a long time ago. Using SSH it works as well. Actually: "--vfs-cache-mode minimal" worked for me. However, I only could copy one file of 27kbs. Whenever I try to copy a 509 kbs file, it says 124 kbs are needed (File explorer Windows). So, every file less than 380kbs can be transferred.

Do you have any idea?


I think you must have installed fuse somehow or the mount command would not work. afaik the synology nas does have fuse installed by default.

I got it on mine, a DS1815+ by installing the sshfs package from the synocommunity repository (Just not sure if that package is available on newer nas models)

Can you copy larger files using SSH, as I copied a 450MB file via SSH

Is your version of rclone on the nas up to date?
I have a vague recollection of seeing something similar when I tried copying stuff when I had the gDrive mounted directly on my Mac, but that was a while ago.

I am afraid I don't use windows, so not really sure what to suggest about that.

Just a thought, as like I say I am not familiar with Windows, but I wonder if when copying using Windows File Explorer it is trying to copy some extended attributes which would not be supported on the gDrive remote.

Does Windows have a way of copying files using the command line? (or install a bash shell if possible) and try copying from Windows that way.


Yes, I think I have the latest rclone as I reinstalled rclone yesterday with:
I, however, tried to copy a file of 400mbs to my encrypted mounter folder and it works! Very weird though...
Still... I mounted my encrypted TeamDrive to /volume1/GTeamDrive/Test10. I can access it with Windows file explorer but I cannot even access /volume1/GTeamDrive/ on the Synology GUI (File Station). It says "Operation Failed".

Do you have an idea how I can fix it?


Furthermore, I remember rclone on Windows with the same TeamDrive encrypted drive was working. However, it does not meed my need. I want to use my NAS as my "gateway" every time so it works every time that I transfer something from my "DS File" on Android or anything else.

I wrote that fusebit wiki...

I am not sure why you cannot access /volume1/GTeamDrive/ on the Synology GUI
as I can at least browse my mount on the Synology GUI (Although it will not copy files using the GUI)

The only thing that is different to mine is that I mount my gDrive inside one of my shared folders.

So I have a shared folder "raiddata" (/volume1/raiddata/) and I mount my gDrive: /volume1/raiddata/gDrive

So I am thinking it could be a permission problem accessing it using the gui

I am not sure how to 'fix' it, I could suggest an alternative, where you have a script and a scheduled task to use rclone copy or rclone move to transfer the files from a folder on the nas to your gDrive

Wow... So the world is not that big after all! :smiley:

/volume1/GTeamDrive/ "GTeamDrive" is a shared folder. However, when I unmount my mounted drive on /volume1/GTeamDrive/Test10, I can access /volume1/GTeamDrive/ without any problem. That is weird.

That is a very smart thing to do! To move files directly with a script. I will dig into it. However, I am quite frustrated and would love to find a solution.

I know, but sometimes Synology just don't make things easy :wink:
Of course you never know, someone might come along with a better solution, but I am not sure there are a huge number of us using rclone on a Synology...

For a script, something like this should work:
(Change the paths to suit your environment).

...and you might want to change
/volume1/homes/user/bin/rclone move
/volume1/homes/user/bin/rclone copy

while getting started

In this example I have saved the script here:

# Make script executable with: chmod a+x /volume1/homes/user/scripts/

if pidof -o %PPID -x "">/dev/null; then
	echo "Process already running"
/volume1/homes/user/bin/rclone move --transfers=2 --fast-list --tpslimit 5 --log-file '/volume1/homes/user/logs/rclonemove.log' --log-level 'INFO' /pathto/folder/on/nas/ gDrive:somefolder

To run it from the command line you can just enter:

and you can check on progress with (in another shell)
tail -F /volume1/homes/user/logs/rclonemove.log

Once you are happy that your script is working, you could add it a as a scheduled task in the DSM Task Scheduler

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.