Synology rclone docker restart loop

What is the problem you are having with rclone?

I am getting a restart loop error.
Failed to create file system for "seedbox:torrents": didn't find section in config file
Do I need to setup a config file before the docker will start? I have tried to delete lines and restart and I get the same error. there are other apps in the docker-compose.yml that all start with no issue. I cant find any info on configuring the rclone config before starting the compose.

Run the command 'rclone version' and share the full output of the command.

Trying to install mumiehub/rclone-mount:latest

I am unable to get the rclone version because it will not finishe the install.

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads

--> unable to do this because it will not start it is in a restart loop.

Which cloud storage system are you using? (eg Google Drive)

Synology NAS Version 7.2.1-69057**

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Here is the part of the docker-compose.yml that is for rclone.

rclone - Docker

When you force remove the container, you have to "sudo fusermount -u -z /host/mount/point" on the hostsystem!

container_name: rclone-mount
image: mumiehub/rclone-mount:latest
restart: unless-stopped
hostname: rclone-mount
driver: json-file
- AccessFolder=/mnt
- 'RemotePath=seedbox:torrents/qbittorrent'
- MountPoint=/torrents
- ConfigDir=/config
- ConfigName=rclone.conf
- 'MountCommands=--allow-non-empty --allow-other --dir-cache-time 1m --no-checksum --uid=${PUID} --gid=${PGID} --umask 002 --exclude temp/**'
- 'UnmountCommands=-u -z'
- ${DOCKERCONFDIR}/rclone:/config
- ${DOCKERSTORAGEDIR}/torrents:/data
- type: bind
source: '${DOCKERMOUNT}/seedbox/torrents'
target: '/torrents'
propagation: shared
- /dev/fuse
- apparmor:unconfined

Paste command here

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

THIS IS THE .env file THAT GOES WITH docker-compose

Here you edit/update your settings that will be used for your docker-compose

This will only work if you follow exactly the path structure in the Guide !!!


Global Settings

<change "/volume1/docker/appdata" with the path your configs will be>


<change "/volume1/data" with the path where your library + torrent/usenet downloads both are>


#rclone mount point


/# <you must find out your PUID/PGID through SSH, run in terminal: id $user. If needed, change $user to the user you cr>PUID=1034



Dockerlogging and max size



Paste config here
``` This is the issue from the logs. I am unable to get the config. Do I need a config file before the container starts?

Paste log here

services.d] [rclone-mount]-run: starting rclone mount 2023.12.31-20:29:58
[services.d] done.
2023/12/31 20:29:59 NOTICE: Config file "/config/rclone.conf" not found - using defaults
2023/12/31 20:29:59 Failed to create file system for "seedbox:torrents": didn't find section in config file
[services.d] [rclone-mount]-finish: rclone process not present, restarting container[ERROR]
[services.d] [rclone-mount]-finish: waiting for rclone shutdown

I have tried to ignore the line in the docker-compose for "seebox:torrents" and restart the compose but the error is the same it just mentions a different line. 

Guy thank you for any help even where I might be able to read to get the info to try and fix it. Please be patient with me. Last year almost killed me three times. Covid, massive Heart attack from blood clots 5 stents 4 heart caths, kidney failure and 2 surgeries. I am trying my best to reactivate my brain and hoping next year is going to be better. 

I have searched for setting up rclone configs but allow found someone using windows and it did fit. I searched for setting up rclone docker config. I am just really at a loss. I dont understand the 3 back ticks. sorry

If this post offends anyone sorry in advance, I am doing my best. thank you for your time and effort.

would it work if I install rclone on a unbuntu server with the all of the info to connect to the other server and then grabbed the rclone.conf from the ubuntu server and edit it then used it on the NAS?

From rclone docs:

You need to mount the host rclone config dir at /config/rclone into the Docker container. Due to the fact that rclone updates tokens inside its config file, and that the update process involves a file rename, you need to mount the whole host rclone config dir, not just the single host rclone config file.

It probably applies to any docker setup so run rclone config locally - create your remote configuration and mount folder containing rclone.conf into your docker.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.