[Synology] Google Authentication link fails

What is the problem you are having with rclone?

I installed rclone via SSH on my Synology NAS and tried to follow the Google Drive setup. I created a client ID and Client Secret which I entered.

When I came to auto config I got to here:

If your browser doesn't open automatically go to the following link:
Log in and authorize rclone for access
Waiting for code...

But that link is useless on my NAS, and when I tried it on my PC nothing loaded.

So I'm stuck.

What is your rclone version (output from rclone version)

rclone v1.54.0

  • os/arch: linux/amd64
  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Synology DSM v6.2.3 64-bit

Which cloud storage system are you using?

Google Drive

I would be thankful for any guidance.

FWIW, I also tried setting this up with the default ID, but ended with the same issue.

hello and welcome to the forum,
when you have a server without a web browser, you need to use headless

Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine or Y didn't work

I'll try that... but first a possibly related question. On my Win laptop, I have an rclone connection to gDrive already.

Can I import that in some way to the NAS? Or copy/paste the gDrive token from the PC remote into the NAS' "Waiting for code" box?

Thank you.

you can copy the rclone.conf file from windows computer to the the nas.
and you should be able to run rclone on both accessing the same gdrive.

after copying the rclone.conf to the NAS, run this command, change remote: to the real name of the gdrive remote
rclone about remote: -vv and you will get a debug log and can see for yourself exactly what is going on with the tokens.

another option, which is what i do, use serivce files, then there are no tokens to deal with.

OK... Setting up a personal Google Drive, I followed the instructions for creating a client ID and secret. When running rclone config, I launched the authorization link, via PC, and got this:

Reading the client_ID details https://rclone.org/drive/#making-your-own-client-id, there is this:

Be aware that, due to the "enhanced security" recently introduced by Google, you are theoretically expected to "submit your app for verification" and then wait a few weeks(!) for their response; in practice, you can go right ahead and use the client ID and client secret with rclone, the only issue will be a very scary confirmation screen shown when you connect via your browser for rclone to be able to get its token-id (but as this only happens during the remote configuration, it's not such a big deal).

While that sound reassuring, I don't see how I get the verification code.

Am I stuck using the client_ID default internal key (low performance)?

i do not use gdrive, but we have many experts, hopefully one will stop by soon.

for now, why not copy the config file from win to nas?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.