Synology access token error

I have a Synology NAS (DS718+) and trying to connect it to pCloud with 'rclone'.
Followed the guideline in GitHub - ravem/synology-pcloud-and-rclone: use rclone to connect, backup or sync your data with pcloud and everything went OK.

Name Type
==== ====
pcloud pcloud

When I received the token from http://localhost:53682/?code=SqDVZcsD5o7ZTHR61f8Et75vfE3GRsFOKS8809KX&locationid=2& I was told by the browser:

All done. Please go back to rclone.

So it seemed that the token was OK but that is not the case ...

Even a simple list of pcloud: creates a 'access_token' problem.

root@nasse:~/.config/rclone# rclone ls pcloud:
2023/02/19 16:53:11 Failed to ls: couldn't list files: pcloud error: Invalid 'access_token' provided. (2094)

Where have I missed?

You missed the whole support template so that would the first thing to fix.

How will this fix my problem?

So we know all the required details to give help you fix your problem.

Your choice :slight_smile:

OK ... I understand.
How do I create a template in this forum?

Please show the effort you've put in to solving the problem and please be specific -- people are volunteering their time to help you! Low effort posts are not likely to get good answers! DO NOT REDACT any information except passwords/keys/personal info. You should use 3 backticks to begin and end your paste to make it readable. Or use a service such as or

What is the problem you are having with rclone?

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

That's the template that comes first post.

Thanks ... I will create a template for this problem.

Problem solved!!!
I discovered that in the Synology 'rclone.config' the hostname was missing ... when I entered correct hostname it worked.
I also made a mistake that I wrote the full token in my post ... does that mean that everyone can access my files ... if so how can a new token be generated or is there another way to avoid unauthorized access.

create a new remote, which should create a new token.

Thanks ... solved my problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.