Syncing network mounted filesystem from windows to google drive


#1

I have a samba share mounted as a z: drive on my win10 system and am interested in syncing contents of some of the folders on z: to a folder on google drive.

I have google drive configured and working with rclone 1.45. I can ls and I was able to do a

rclone copy c:\users\Deadcalm\Music remoteg:backups

but when I try

rclone copy z:\shared_documents remoteg:backups I get an error that the source directory cannot be found.

Should this work, or is there an implicit issue with syncing a network share in this manner?
Is there any way around this?


#2

update:

I’ve created a symbolic link to a local folder like…

mklink /d c:\Users\Deadcalm\backups\shared_documents \192.168.0.100\Disk0\shared_documents

then tried…

rclone copy c:\Users\Deadcalm\backups\shared_documents remoteg:backups

and was error’d with “use -L” so I did and it’s chugging along happily copying the folder.


#3

It should work with shared drives…

Can you try rclone lsf z:, rclone lsf z:\ and rclone lsf z:\shared_documents do any of those work? is the directory called exactly “shared_documents” or could it be in a different case?


#4

So all three commands with z:, z:\ and z:\shared_documents result in the same source directory not found error. I tried with upper case z in the first two also with the same result.

I am able to do rclone lsf \192.168.0.100\Disk0 successfully, so it does appear to work on the shared drive, just not with the drive letter windows is using. Odd.


#5

Odd indeed. Can you please make a new issue on github about this. I don’t promise a speedy fix but someone else reported this so I can collect reports in the same place.

Can you put a link to the forum thread too please.


#6

ok…was logging the issue on github when I think I figured out the problem, thought I don’t totally understand it…

I was doing all this in a command prompt with admin rights (can’t remember why). For some reason this seems to prevent me from referencing the shared letter at all. I was trying to include a dir of the share to show that it existed but the command prompt didn’t like that either. Anyway, long story short, when I switched to a standard command prompt without admin rights I can dir the drive letter and was able to do a successful rclone lsf z:

Let me know if you’d like me to continue logging the issue, though it doesn’t appear to be a problem with rclone at all. Thanks again for your help.


#7

Ah ha!

It does say this in the docs

Note that drives created as Administrator are not visible by other accounts (including the account that was elevated as Administrator). So if you start a Windows drive from an Administrative Command Prompt and then try to access the same drive from Explorer (which does not run as Administrator), you will not be able to see the new drive.

No need to make an issue, and glad it is solved for you :smile: Sorry I didn’t figure out the problem.