Sync Google Drive to Google Drive - google docs timestamp not retained

What is the problem you are having with rclone?

I need to move all of my files from my school google drive account and since there is 150gb, I've got a google workspace account and created a shared drive to move all of it. Jfyi, this school drive folder, I also have some docs owned by my free "gmail" account. I'm ok for all of the owerships to be moved to a single owner in the target workspace shared drive.

I'm doing a test run to see how this works and I'm seeing a couple issues.

  • for the "google docs" - its not retaining the time stamps info. I did notice that the create date is not being retained for any of the files, not sure if that is a limitation but the last modified date is being reflected correctly in the non "google docs". But for the google docs - the modified and create date is the timestamp of when this was run.
  • it also appears to have lost the history of changes.

I also did see that in this test folder one of the files was owned by my gmail account, but rclone was able to create it in the shared drive - with the ownership belonging to the workspace org.

I'm I using the command correctly?

Run the command 'rclone version' and share the full output of the command.

macpro ~ %    rclone version
rclone v1.52.2
- os/arch: darwin/amd64
- go version: go1.14.4

Which cloud storage system are you using? (eg Google Drive)

Google Drive  to Google Shared Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

macpro ~ % rclone --drive-server-side-across-configs --log-file=rclone-log1.txt -vv -P --fast-list sync bDrive:temp pDrive:temp

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
scope = drive
token = XXX
client_id = XXX
client_secret = XXX
root_folder_id = XXX

type = drive
scope = drive
token = XXX
team_drive = XXX

A log from the command that you were trying to run with the -vv flag

I've been runnign this a few times to test so looks like I've hit the quota limit - but here is the log any way.

Thanks much in advance for your help!

This is ancient version - many years old. Try with the latest rclone.

welcome to the forum,

correct, modtime is not supported for google docs.

my bad, I had the older ver and then in one of the support articles sit asked me to do a selfupdate which I did and it didn't work, bcos it was too old.

So I did a new install, but forgot to update this section. The version I'm using is
rclone v1.66.0

  • os/version: darwin 14.0 (64 bit)
  • os/kernel: 23.0.0 (arm64)
  • os/type: darwin
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.22.1
  • go/linking: dynamic
  • go/tags: cmount

aplogies for that. thanks!

1 Like

this says for google photos, I'don't have any pics just google docs, slides and sheets. thanks