Sync and Cryptcheck

What is the problem you are having with rclone?

Sync reports "Nothing to transfer" but Cryptcheck reports "2 differences found" when sending to a encrypted remote.

What is your rclone version (output from rclone version)

rclone v1.52.0
os/arch: linux/arm
go version: go1.14.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Raspbian ARM

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -v /directory encrypted_b2:


rclone cryptcheck -v /directory encrypted_b2:

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

Sync returns Size of src and dst objects identical for all the files but cryptcheck retports hashes differ


Also tried

rclone sync -v --checksum /directory encrypted_b2:

But informs that --checksum is in use but the source and destination have no hashes in common; falling back to --size-only. Which explains the problem since it only looks for the size and not the content.

What I think happened is that the two local files were modified but

  • their sizes were unchanged
  • their modification times were unchanged

Can you see if that is the case?

What kind of files are they?

The modification times changed, I found that if I use --use-server-modtime on the sync command it works.

If the modification times were changed then the the sync should have picked that up when you tried it without --checksum

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.