Symlinks with posixovl over rclone

Today I have mounted a mega drive on my kubuntu 18.04 pc with rclone.
All right (but I believe you should say that there ought be “&” after the folder to mount).
I planned to use symlinks on mega drive trough posixovl, but so far I cannot (permissions error message when I try to create a symlink).
This my code:

rclone mount mega:schede /media/duns/webdav-schede & # --umask int

(something wrong?)
It’s possibile create a symlink in that way?
Thank you

Symlinks generally don’t work when you cross file systems. What are you trying to do?

Thank you. Posixovl provide a workaround, at least with local devices. So I created successfully symlinks on my e-reader (vfat): these are small hidden files but in a certain disk partition (mounted via posixovl) they are really seen as symlinks.
I wonder if you can not use posixovl even remotely: with webdav I have already seen that it is impossible, now I’m trying with rclone and I would like to understand if rclone grants permission to posixovl.
In particular I don’t undestand how use (if useful) flag --umask (I get an error message; is correcty the code above?)

You can’t create symlinks on a fuse mount with rclone though so that’s why I’m not sure what you are trying to accomplish.

Umask works the same as in Linux.

I use:

--umask 002

on my mount command to give read/group read/write/execute and read/execute for other.

So what are you trying to do?

ln -s somefile someotherfile? Symbolic links or hardlinks?

Symbolic links, as in local with posixovl. I see an interesting discussion: many people want symbolic links on clouds.
I get this error message:

~$ rclone mount mega:schede /media/duns/webdav-schede & --umask 002

[1] 27924 --umask: command not found

The & puts the command in the background so you’d have to put all your arguments before the “&” sign if you want them to work.


rclone mount mega:schede /media/duns/webdav-schede & --umask 002

would be

rclone mount mega:schede /media/duns/webdav-schede --umask 002 &

ops… thank you. Now it’s ok.
But I have already seen that in remote the permissions should be good…

$ umask -S   u=rwx,g=rwx,o=rx

So the problem is rclone and symlinks…

Yes, you’d have to wait for the issue to get fixed.

But I downloaded the zip file and I spent some time to modify local.go as here is shown: can you kindly tell me how can now compile rclone from (this modified) source?
Thank you

You’d have to pull from that repo: is how to install from source.