Symlink and extend attribute unsupported on macOS?

What is the problem you are having with rclone?

I am using Rclone(rclone mount) on macOS, I am so confused with the two following questions:

  1. Is the extended attributed still no supported yet in the latest version?
    If so, how can I solve this problem? I tried using "cp -X" which works on macOS 12/13, but not working on macOS 14(sonoma.), the extended attribute can't be removed at all. I consider it perhaps a new
    macOS security feature

    It is quite annoying when copy files from local filesystem to the disk(mounted by rclone). I have to remove the extend attributes first and then copy(I have to deal with the root permission files located at ~/Desktop or ~/Downloads or ~/Documents which is totally a disaster to me.).

  2. Is the symlink still no supported yet in the latest version?
    I find it seems symlink is still not supported now.

Run the command 'rclone version' and share the full output of the command.

rclone version: v1.58.0

  • os/version: darwin 14.0 (64 bit)
  • os/kernel: 23.0.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.21.1
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

  1. rclone mount XXX
  2. cp src_path dst_path[rclone] : Error: fcopyfile failed: Operation not permitted
  3. ln -s a.txt dst_path[rclone] : ln: dst_path[rclone]: Function not implemented

welcome to the forum,

that is an old version of rclone
can update using rclone selfupdate and test again.

Could you confirm these problems are fixed?

Neither links nor extended attributes are supported.

but cp -X should work.

Install the latest rclone version (nobody will investigate years old version issues) and try cp -X again.

If it does not work provide all details including mount debug log - it should shed some light on what is going on.

In general I avoid mount on macOS as neither macfuse nor fuse-t are trouble free (with characters encoding being the biggest problem for me) and use rclone cmd directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.