Switch to set config directory


I need a rclone command that picks up my config file. Please don't send me to rclone/documentation because I don't manage to understand what switch to use... :wink:

My config file I find this way:

  1. Putty to NAS (SSH)
  2. sudo -i
  3. Dir ---->

root root feb.23. 07:34 .config

So what the path to it I not know (lets use on example from DOS c:\rclone\config)

A switch guess can then be:

rclone configpath: c:\rclone\config copy /volume1/Doc JottaNAS:Doc

So I hope to get help to find this switch in bold letters.



add this to your command, need to specify the exact file
this is the documentation

and if you cannot find the config file

Thanks: @asdffdsa


so switch is --config=, one step further. Thanks

This is from my example, and it was like a C drive. I don't have it on a PC. My conf is on the nas and i dont konw how to find the path. Yes, i dont understant where on my nas my conf file is. Newbee...

My config file I find on my NAS this way:

  1. Putty to NAS (SSH)
  2. sudo -i
  3. Dir ---->

root root feb.23. 07:34 .config

This means that the path is on root after i sudo -i, but the path syntax is unknown for me.

can it be like:

rclone --config=/volume1/config copy /volume1/Dok JottaNAS:Dok ?

rclone config file                                                                                                            [33/33]
Configuration file is stored at:
rclone listremotes --config=/home/user01/.config/rclone/rclone.conf

and the nas unit, is it synology, qnap or what?

Holy cow, I finally solved it in DSM (Synology)

My desert journey (ørkenvandring in NO) was trying to config rclone from command line. In Synology UI i fond the answer, root user did find config file by itself, so if correct user is running the script then rclone is running without a path to rclone config file.

In time sceduler had wrong user. I changed to user :root

with user:root it runs



command i run:

rclone copy /volume1/Doc/ NAS:Doc--log-file=LogDok.txt


Now i wait and see what errors I get in the log

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.