Supported options for Docker Volume Plugin

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

I want to mount an S3 bucket inside in a Docker container. The Docker Volume Plugin is a neat and portable method of achieving this. I create this volume through docker-compose, mostly with success.

My confusion lies with the driver_opts property. According to the documentation of the plugin, I should be able to specify backend and mount options, which (to the best of my knowledge) are specified here and here respectively:

Rclone flags and volume options are set via the -o flag to the docker volume create command. They include backend-specific parameters as well as mount and VFS options

However, when I try to set certain mount options, such as vfs_fast_fingerprint: "true", I get the following error, even though this flag is included in the aforementioned list of mount options:

create myvolume: VolumeDriver.Create: unsupported backend option "vfs_fast_fingerprint"

Another example that is not supported, even though it seems like it should be, is vfs_disk_space_total_size. Most other options, such as vfs_cache_mode and no_modtime work as expected. Which leads me to wonder why some options work and some don't. Am I simply looking at the wrong list of available options, is the documentation wrong or are these options supposed to be available but do they still need to be implemented?

Run the command 'rclone version' and share the full output of the command.

NB: i think the following is more relevant to this situation

PLUGID=$(docker plugin list --no-trunc | awk '/rclone/{print$1}')
sudo runc --root /run/docker/runtime-runc/plugins.moby exec $PLUGID rclone version

output (this is the latest version at the time of writing):

rclone v1.62.2
- os/version: alpine 3.17.2 (64 bit)
- os/kernel: 5.10.0-22-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Amazon S3 compatible

The command you were trying to run (eg rclone copy /tmp remote:tmp)

N/A (docker compose)

The rclone config contents with secrets removed.

Volume is created config-less, but these are the relevant flags.
With the following VFS options, the volume is created successfully:

  vfs_cache_mode: full
  vfs_cache_max_size: 100G

Volume creation does not work with these settings:

  vfs_cache_mode: full
  vfs_cache_max_size: 100G
  vfs_fast_fingerprint: "true"

A log from the command with the -vv flag


It looks like those options are missing from the parser

Do you want to send a PR to fix?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.