Support for mega

What is the problem you are having with rclone?

Cannot find backend for mega in rclone 1.53 installed from MXLinux 21 'WildFlower'

$ rclone help backends
All rclone backends:

  alias        Alias for an existing remote
  acd          Amazon Drive
  azureblob    Microsoft Azure Blob Storage
  b2           Backblaze B2
  box          Box
  crypt        Encrypt/Decrypt a remote
  cache        Cache a remote
  chunker      Transparently chunk/split large files
  drive        Google Drive
  dropbox      Dropbox
  fichier      1Fichier
  ftp          FTP Connection
  gcs          Google Cloud Storage (this is not Google Drive)
  gphotos      Google Photos
  http         http Connection
  swift        OpenStack Swift (Rackspace Cloud Files, Memset Memstore, OVH)
  hubic        Hubic
  jottacloud   Jottacloud
  koofr        Koofr
  local        Local Disk
  mailru       Mail.ru Cloud
  memory       In memory object storage system.
  onedrive     Microsoft OneDrive
  opendrive    OpenDrive
  pcloud       Pcloud
  premiumizeme premiumize.me
  putio        Put.io
  s3           Amazon S3 Compliant Storage Provider (AWS, Alibaba, Ceph, Digital Ocean, Dreamhost, IBM COS, Minio, Tencent COS, etc)
  seafile      seafile
  sftp         SSH/SFTP Connection
  sharefile    Citrix Sharefile
  sugarsync    Sugarsync
  union        Union merges the contents of several upstream fs
  webdav       Webdav
  yandex       Yandex Disk

rclone version:

$ rclone version
rclone v1.53.3-DEV
- os/arch: linux/amd64
- go version: go1.15.9

Which cloud storage system are you using? (eg Google Drive)

mega.nz

I did find a support page for mega in the rclone forum, and (from memory) believed that I had seen support for mega in earlier versions of rclone

Is mega supported ?

thanks
Malcolm

hello and welcome to the forum,

the latest version is v1.59.1
https://rclone.org/downloads/#script-download-and-install

https://rclone.org/changelog/#v1-41-2018-04-28

Thank you for your advice.
You showed me confirmation that mega support has been in rclone since v1.41 in 2018, so I'm surprised that it's not included in the version 1.53-DEV that I installed from my linux distribution's repositories.
I'm using sysv init. Do current linux versions of rclone depend on systemd ?

I think Debian removed mega support because of some license issue, so you'll have to use the version from rclone.org

Thank you Nick, mystery resolved. I'll download the latest from rclone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.