Super-fast GDrive MOUNT option, please test and confirm!

#1

I don’t know if this has been tried/discovered before, but here’s a config I tried out this morning and it’s working extremely well and extremely fast for me so far. In a nutshell, I’m letting Google Drive File Stream take care of all the heavy lifting when it comes to indexing, syncing and caching my remote crypt. Then I’m using rclone running a local crypt to view/browse all of the files.

The reason for this setup is primarily so I can quickly work through a large file set using the macOS finder.

rclone config:

[local]
type = local

Just the default local setup, no config options

[secure]
type = crypt
remote = local:/Users/psmith/mnt/server
filename_encryption = standard
directory_name_encryption = true
password = *** ENCRYPTED ***

And here’s the magic.

  1. Create a symlink in your macOS terminal to your encrypted folder that Google Drive File Stream has already indexed for you:

ln -s /Volumes/GoogleDrive/My\ Drive/Server /Users/psmith/mnt/server

  1. Mount your crypt using the commands you prefer. I am currently using this command:

rclone mount --allow-other --no-modtime --log-file logfile.log -v secure: ~/mnt/gdrive &

This leaves me with:

/Users/psmith/mnt/server - a symlink that points to the encrypted folder that Google Drive File Stream has indexed and cached

/Users/psmith/mnt/secure - my mounted, decrypted version of the folder above

And finally, a macOS Finder tweak that seems to help speed up browsing quite a bit: turn off Show icon preview and Show preview column

1 Like

#2

Couple things that are confusing.

If you are using Google Drive File Stream, you don’t need your own API key.

–fast-list doesn’t do anything on a local mount.
–allow-non-empty is generally bad as you get into over mounting situation and imo, shouldn’t be used.

You can just point your rclone to your Drive Stream location with no symlink. Any reason for the symlink?

0 Likes

#3

ahh, you’re right. I just pasted in my gdrive config in excitement. Didn’t know that about --fast-list either.

When I first tried i setup my crypt as:

local:/Volumes/GoogleDrive/My\ Drive/Server

and rclone threw an error when I tried to mount. I figured it had something to do with either the space in the folder structure or perhaps something that File Stream was doing to prevent it from working.

I’ll edit my first post to reflect your suggestions.

0 Likes

#4

Found an issue, not sure how to fix it yet:

I can rename and delete files, and rename folders. However I am not able to delete folders.

macOS gives the error “The Finder can’t complete the operation because some data in “foldername” can’t be read or written.
(Error code -36)”

rclone log gives the following, which doesn’t seem very helpful:

2019/03/15 11:05:43 DEBUG : : >Statfs: stat={Blocks:122045436 Bfree:71941749 Bavail:71941749 Files:1000000000 Ffree:1000000000 Bsize:4096 Namelen:255 Frsize:4096}, err=<nil>
2019/03/15 11:05:44 DEBUG : _trash/: ReadDirAll: 
2019/03/15 11:05:44 DEBUG : _trash/: >ReadDirAll: item=2, err=<nil>
2019/03/15 11:05:44 DEBUG : _trash/foldername/: Lookup: name="Contents"
2019/03/15 11:05:44 DEBUG : _trash/foldername/: >Lookup: node=<nil>, err=no such file or directory
2019/03/15 11:05:44 DEBUG : : Statfs: 
2019/03/15 11:05:44 DEBUG : : >Statfs: stat={Blocks:122045436 Bfree:71941749 Bavail:71941749 Files:1000000000 Ffree:1000000000 Bsize:4096 Namelen:255 Frsize:4096}, err=<nil>
2019/03/15 11:05:48 DEBUG : /: Fsync: 
2019/03/15 11:05:48 DEBUG : /: >Fsync: err=<nil>
2019/03/15 11:05:48 DEBUG : /: Attr: 
2019/03/15 11:05:48 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxr-xr-x, err=<nil>
0 Likes

#5

Hmm, I hadn’t used file stream on my Mac before and testing it out, it seems to hang up quite a bit for me. I’ll goof around with it a little more.

I guess it depends on the use case and what needs to be done.

0 Likes

#6

Yes, I have been doing this for a while on my Mac. I have some of the data in my drive encrypted with Rclone so File Stream works great for non-encrypted data but is useless for the encrypted stuff. You can “remount” it with Rclone when necessary or use a tool like Rclone browser as a GUI front-end for check and grooming files and such (though be careful with moving files with Rclone browser).

0 Likes

#7

Have you had any access with deleting folders using this method? I’m still not able to and it’s become quite frustrating

0 Likes