Strange behavior with GDrive remote using Google Workspace account


I have problems getting rclone to work properly with a Google Workspace (what used to be GSuite) account.

I run a Google Workspace for Education Fundamentals with a university's domain.
I created a user account for making backups. Then I created the project and got an ID and secret.
Then, I ran the rclone config, put the Id and secret, got the token and It seemed to work.

Here the problems start:

When I copy a file to the remote I get no errors, but the file doesn't show on the gdrive web. I put the scope at "full access", so It should be there.
When I run rclone ls googledrive the file is listed, though.

When I run rclone about googledrive I get:

Total:   19.066G
Used:    8.209G
Free:    9.866G

Which is wrong, because Google Workspace gives me 100TB of shared storage, there is no personal storage space for each account (only a 750GB upload limit per day). Plus, I don't know where those 8G of used space come from, since I only uploaded a small .txt file.

Also, if I upload a file to drive using web interface, It doesn't get listed with rclone ls googledrive. It's like they are two different accounts, except they're not. I specifically created the user for this purpose, It has never been used, nor is it a migration from a personal google account. And there's no other rclone remote configured, so I can't be uploading to the wrong drive account.

Any guidence would be appreciated.


$rclone version
rclone v1.55.1
- os/type: linux
- os/arch: amd64
- go/version: go1.16.3
- go/linking: static
- go/tags: none

I'm using Ubuntu 20.04.


$rclone config show
type = drive
client_id =
client_secret = XXX
scope = drive
token = {"access_token":"XXX","token_type":"Bearer","refresh_token":"XXX","expiry":"XXX"}

hello and welcome to the forum,

please copy a single file to the gdrive, add -vv to the command.
post the entire output.

Thanks for replying.
Here's the output:

$ rclone copy test.txt googledrive -vv
<7>DEBUG : Using config file from "/home/superman/.config/rclone/rclone.conf"
<7>DEBUG : rclone: Version "v1.55.1" starting with parameters ["rclone" "copy" "test.txt" "googledrive" "-vv"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Creating backend with remote "test.txt"
<7>DEBUG : fs cache: adding new entry for parent of "test.txt", "/home/superman"
<7>DEBUG : Creating backend with remote "googledrive"
<7>DEBUG : fs cache: renaming cache item "googledrive" to be canonical "/home/superman/googledrive"
<7>DEBUG : test.txt: Need to transfer - File not found at Destination
<7>DEBUG : test.txt: MD5 = 57fd97b327bc1b2b0808ebb588280267 OK
<6>INFO  : test.txt: Copied (new)
<6>INFO  : 
Transferred:   	         9 / 9 Bytes, 100%, 38.772 kBytes/s, ETA 0s
Transferred:            1 / 1, 100%
Elapsed time:         0.0s

<7>DEBUG : 3 go routines active

Same result: it get listed with rclone ls but it doesn't appear on the web.

the correct command would be
copy test.txt googledrive: -vv

a rclone remote needs a colon character in it, :.
without that colon, rclone considers it a local path.

this can be seen in the debug log.
renaming cache item "googledrive" to be canonical "/home/superman/googledrive"

so if you ls /home/superman/googledrive, you should see test.txt.

this documented at

I can't believe I made that mistake. Thanks!
Now it lists the the files i upload with rclone and the files uploaded from the web.
Now, the only remaining problem is the quota size.

$ rclone about googledrive:
Used:    54.468k
Trashed: 0
Other:   0
$ rclone about googledrive
Total:   19.066G
Used:    8.794G
Free:    9.281G

So, if I put the colon at the end, I get the correct used space, but I get no info on the free space. But when I don't put the colon, I get the same result as before. I should have the 100 TB of shared space from my Workspace subscription, not 20 Gb.
Any ideas about that?
Thanks again.

EDIT: according to the docs, with rclone about googledrive: I should get the amount of total and free space, but I only get what I pasted before. It also says that no all backends show all the info, but I thought GDrive did. Do you happen to know for a fact if the GDrive backend shows the total and free space info or not?
(rclone about)

as i pointed out, googledrive is a local folder on your local computer, not the gdrive account.

i do not know what, tho i have read that gdrive educational accounts, are in some way different from a normal account.

when i run the same command

rclone about gdrive-a1b2:
Total:   15G
Used:    1k
Free:    14.975G
Trashed: 0
Other:   25.844M

Yes, I understand now that googledrive without the colon points to the folder in my local machine.
I had the same result as you with personal accounts, i.e., it shows all the data, that's why I was trying to get the same result with the workspace account. But you're probably right, they must be different in some way. Maybe google doesn't show the total space because it's shared, not belonging to the account I'm using.
Thanks again for all your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.