Stopping action when rclone cannot connect to target

What is the problem you are having with rclone?

When calling rclone purge target: and the host ip from target is not reachable rclone tries endlessly to connect. I tried with the retries flag, but the try never fails, so this does not fix it. Any ideas what to do? I want it to just fail if the host ip is not reachable

Run the command 'rclone version' and share the full output of the command.

clone v1.59.0

  • os/version: alpine 3.16.0 (64 bit)
  • os/kernel: (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.18.3
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone purge --progress --retries 1 target:

The rclone config contents with secrets removed.


A log from the command with the -vv flag

no log cause it just keeps going and I want it to fail

The number of times it tries should be controlled by --low-level-retries - did you try that?

I tried
rclone purge --low-level-retries 1 --progress target:
but is the same outcome

thats the error I get, but why does it not stop with that error?
I am working in a docker environment

and sometimes it looks like this

Instead of sharing a screen, can you share a full debug log with the backtics around it as text.


Purge will retry a number of times before failing so seeing the full command/debug log

rclone purge --low-level-retries 1 --progress target: -vv

Is what we want to see.

yeah sorry of course

But reading the dump file myself i realized the 2 retry flags work together
so setting both to 1 reduce the amount of time rclone tries to connect.
So thank you!

Yes the low and high level retries multiply.

Normally it doesn't take 20s to see each failure.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.