Still fail because SetModTime failed when --no-update-modtime is set


#1

Hi I run the command as:
rclone copy gs:somebuket/ sftp:uploads/something -v --no-update-modtime --size-only

The source type is google cloud storage, the dest type is a sftp server that I have limited access to (cannot modify modtime I assume).
Even though the file transfer are success, I still get
2017/04/27 15:15:15 ERROR : FILE_NAME: Failed to copy: Update SetModTime failed: SetModTime failed: sftp: “Permission denied” (SSH_FX_PERMISSION_DENIED)

I figured --no-update-modtime means --no-update-modtime-if-file-identical
Can we have a --no-update-modtime?

Thanks!


#2

For a sftp remote I believe you can use --sftp-set-modtime=false instead of --no-update-modtime. That should turn off the modified time for an sftp remote. I’m not sure if that’s a bug or maybe sftp just needs to be handled more specifically.


#3

Those two flags do slightly different things. --sftp-set-modtime=false turns off modtimes completely (note you can set this in the config too as set_modtime = false) whereas --no-update-modtime only turns off modtime updating in the case that the files were identical but had different modtimes.