Status sftp "input too short when revealing password" problem

What is the problem you are having with rclone?

I'm trying to use rclone in config-less mode to access (in this case list) a password protected sftp.
Basically trying to use the command here:

(I can't include link but this is the forum question, replace @ with slash and & with dots): forum&rclone&org@t@syntax-for-config-less-operation@12011@4

What is your rclone version (output from rclone version)

root@PC-IT-UBUIEX:~# rclone version
rclone v1.55.1

  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.3
  • go/linking: static
  • go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd --sftp-host --sftp-user this_user --sftp-pass this_pass :sftp:

The rclone config contents with secrets removed.

none (trying config less)

A log from the command with the -vv flag

2021/06/13 06:59:29 DEBUG : Using config file from "/home/install/.config/rclone/rclone.conf"
2021/06/13 06:59:29 DEBUG : rclone: Version "v1.55.1" starting with parameters ["rclone" "lsd" "--sftp-host" "sftp...***" "--sftp-user" "this_user" "--sftp-pass" "this_pass" "-vv" ":sftp:"]
2021/06/13 06:59:29 DEBUG : Creating backend with remote ":sftp:"
2021/06/13 06:59:29 DEBUG : :sftp: detected overridden config - adding "{wIySZ}" suffix to name
2021/06/13 06:59:29 Failed to create file system for ":sftp:": input too short when revealing password - is it obscured?

Solved, the solution is here:


Welcome to the forum.

Glad to see you found the solution yourself. :+1:

Posting real links, for future readers:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.