Split folder using move –max-transfer doesn’t work at same drive

What is the problem you are having with rclone?

I'm trying split a huge folder to smaller folder size using move --max-transfer, but when I try to do it at the same drive, every file is moved, it's like --max-transfer was ignored

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: debian 11.7 (64 bit)
  • os/kernel: 6.1.64-ophub (aarch64)
  • os/type: linux
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone  move  qq:/pik qq:/dow/12-26    --cutoff-mode=cautious --max-transfer  150g  --min-size  15g  --tpslimit 4     --progress

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

Paste config here

A log from the command that you were trying to run with the -vv flag

Paste  log here

when i try --disable DirMove,Move, it cant move

This flag takes into account only real transfers between remotes and not server side moves. So unfortunately you can not use it in the way you described.

So is there any way to do it?

Not with rclone flags only AFAIK. You can use rclone move but you have to manage it yourself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.