Specific folder in the configuration file

I followed these steps...

nc02

Which go did you install - the latest 1.13.x? If not, then install that.

Did you set GOROOT or GOPATH - if so then try with then unset - you shouldn't need them.

Version 1.13.7
always the same mistake ...
C:\go\src\rclone>go build
build github.com/rclone/rclone: cannot load archive/zip: malformed module path "
archive/zip": missing dot in first path element

I'll create the development environment again, reinstall everything: Go, MinGW, WinSfp, and download the rclone ...
I inform you of results ..

I found some tutorials confusing on the web, is there a place where the information is more accurate?

Thanks! nc03

You don't need MinGW or WinFSP if you build without cgo - just rclone build builds without cgo. That means you won't be able to rclone mount but should be fine for this change.

This is how I set it up on Windows last time I build an rclone dev environment

Is there anything @ncw hasn't thought of?

The alias resolves partially, but the main source needs to be exposed in rclone.config to work.
we are studying a way of not leaving the entire cloud exposed, using a single configuration..

nwc03 I managed ... only with Go and Source.
The problem was the folder ...
I put it in C: \ github.com \ rclone \ rclone

I will work hard now!
Ps: I'm using a Windows 8.1 64 PRO VM

Thank you!

1 Like

ncw,

My knowledge is still very limited, but it follows a first idea.

In my tests it worked well, but you need to see some implication in the code set.

Changes were made only to the pcloud.go file

Ps: Your code is very clean and professional, congratulations!


I await your comments.

Thanks!

Just an explanation about this:
Many users work on their clouds for backups and can do this on PCs or servers that they control.
In my case, I have 6 TBs on Pcloud and I share this space with several different users.
That is why it is important for me to preserve root access for any other user.
I believe that this way of informing the initial folder will help me a lot.

That looks like it will work!

Can you follow what I said here: https://github.com/rclone/rclone/issues/3957#issuecomment-585139396

for making the config variable. This will mean you don't need the GetRootID function and that the setting will appear in the rclone config menu.

ncw,

Thank you for the tips!

See the changes I made at pcloud.go!

Well, it's working well here ...
Would it be this!

Thanks!!


pcloud00|690x487

That is looking better! Do you want to make a pull request? It is easier to review code on GitHub?

There is! it is much better ... I believe that within the scope!

It's my first time, I don't know how to do this.

Do I need to send you the file with the changes? how to do this? rss

Do you think this procedure is necessary?

Here are GitHub's instructions on how to make a Pull request.

If you do that then your code will be automatically checked also.

Something specific that I should search for / insert?

What am I missing!
hehehe...!

What did you call the branch on your fork? The default is master so if you didn't change it, that is what you want.

That, it was automatic!
If necessary I delete the account and create it again!
Thanks!!

Would it be conceivable in the design record to just educate a particular envelope? keeping away from access to the whole cloud?

Mitchel21, This is the goal ... but using the folder ID.

Great work. Is it going to be released?