Special characters in config name

What is the problem you are having with rclone?

I want to use some special characters in my config remote name. For example, to include the email address of the cloud remotes in their config. However, when I try this, it is not accepted. The following error crops up:
"config name contains invalid characters."

How can I go around this issue?
I should be able to include the email in the config name.

Hi Yolo,

Seems like it should be possible if using v1.61+:

Remote names are case sensitive, and must adhere to the following rules:

  • May contain number, letter, _, -, . and space.
  • May not start with - or space.
  • May not end with space.

Starting with rclone version 1.61, any Unicode numbers and letters are allowed, while in older versions it was limited to plain ASCII (0-9, A-Z, a-z). If you use the same rclone configuration from different shells, which may be configured with different character encoding, you must be cautious to use characters that are possible to write in all of them. This is mostly a problem on Windows, where the console traditionally uses a non-Unicode character set - defined by the so-called "code page".


Hey Ole,

Thanks for the response. While it seems possible, I am still unable to achieve the naming convention mentioned above.

It seems that the "@" character is causing the problem. Can't I include the "@" character in the config name, as email addresses contain the specified character?

If that explains anything, I am working with the config on a Windows environment.

I did a quick test and see the same using PowerShell on Windows:

PS> rclone version
rclone v1.62.0-DEV
- os/version: Microsoft Windows 11 Home 22H2 (64 bit)
- os/kernel: 10.0.22621.1105 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.19.2
- go/linking: static
- go/tags: cmount

PS> rclone config 
n) New remote
e/n/d/r/c/s/q> n
Enter name for new remote.
name> a@b
Can't use "a@b" as config name contains invalid characters - may only contain numbers, letters, `_`, `-`, `.` and space, while not start with `-` or space, and not end with space.

It may be my PowerShell settings, I haven't investigated.

I suggest we wait until somebody using v1.61+ on Linux has tried.

Unicode "letters" is allowed, not any symbol. I assume that is the case.. At the phone, so unable to test more myself right now.


1 Like

This is the same error that I run into. It might be possible that the PowerShell limitations are causing it.
Anyone who can test it on Linux is welcome to test.

That might also be the issue here. It is kind of hard to figure out and a linux tester might help in confirming this.

The GitHub issue linked by @albertony contains a post where @ncw has made a very illustrative test program to test config names : https://go.dev/play/p/De14w8o1WRp

I have added "a@b" to the examples in this test program giving this result when pressing Run:

Nguyễn Nhật Lâm
Hồng Thị Nhung
Nguyễn Thị Phượng
Lâ Minh Chánh

I suggest you read the entire GitHub thread to understand the considerations behind the choices made.

My impression is that rclone behaves as designed/expected, because @ is considered a Unicode punctuation, which can be seen by this slightly modified test program. I am not enough into the details to know if (all Unicode) punctuations can be easily added (without adverse side effects).

1 Like



Well, I don't want to beatify the config name only to make things go haywire. I was testing out the different possibilities and came across the said issue. Implementing punctuation without the so-called 'adverse' effects would have been an excellent inclusion.

Also, what might be the adverse effects?

I will wait for someone on Linux to test it out as well. If nothing comes out, this might be the solution that I was looking for.

The above test program shows that Linux users will see the same.

"not:a/good/idea!" cannot be a config name, how to decide what is config name and what is path?

Think: remote/with:in/the/name:some/folder/

So obvious. Thanks for pointing it out, Ole.

Since I am so adamant in naming the config with the "@" character, anyway to achieve this (since it has already shown as a good naming in the program)?

I am not going to do any operations, just want to see if we can achieve this somehow (in powershell).

It requires a change to rclone, so your next step would be to create a new forum post of type Feature, so the pros and cons can be discussed.

I suggest you include

  • a reference to this thread
  • an example showing how this improves rclone
  • an indication of your interest in sponsoring or developing this for rclone
  • a proposed phrasing of the new rule to replace this:

I didn't have this in mind when I initially created the topic. However, I might as well request for the change and see if it can be implemented. It will be pretty helpful for those with multiple remotes.

Thanks for pointing me in the right direction Ole. Not just this suggestion but also the marked solution.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.