Sparse file should not be sync

What is the problem you are having with rclone?

Some applications create sparse files instead of pre-allocation such as qbittorrent. Qbittorrent first create a sparse file with a large size and fill them later. But rclone mount upload its sparse size to the remote once write back timeout is over, which is extremely inefficient.

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Hi Julian,

You posted this a suspected bug, but it looks like a wish for an improvement of rclone.

I therefore suggest you create a new thread of type Feature where you will get the right attention and discussion of your proposal.

If it is indeed a suspected bug, then please fill out all the requested information with a condensed example illustrating the suspected bug.

The remote do not support sparse files so it has no choice but to upload the whole file.

hello and welcome to the forum,

not sure your use case but i prefer to download a torrent to local storage, not using rclone mount.
when the torrent has finished downloading, the torrent software runs a script using rclone move.

Alas cloud storage providers don't support sparse files in general.

It would be possible to have a block based overlay file system (I have a prototype somewhere) which you'd layer over a normal fs to enable this.

(I did the prototype to test out mounting a file system image on rclone. It wasn't wildly successful!)