Source directory not found

Hello Everyone -

I ran into this source directory not found error. Its on a linux server. I had granted 777 to the file that at this /tmp location to see if that resolves the issue. No luck.

It appears to me, rclone tried to create a cache file and failed. So, wondering if there's an option to disable caching option or if there's a way to set the path to create that cache file at a different location that user has read/write access to it.

I appreciate if anyone has any suggestion on this can be resolved.


2023/03/22 12:45:25 DEBUG : Using config file from "/xxxx/rclone.conf"
2023/03/22 12:45:25 DEBUG : rclone: Version "v1.55.1-DEV" starting with parameters ["/usr/bin/rclone" "-vv" "--retries" "1" "--config=/xxxx/rclone.conf" "copy" "/tmp/xxxxxx_MIGR_01.DMP" "migration:migr-bucket"]
2023/03/22 12:45:25 DEBUG : Creating backend with remote "/tmp/xxxxxx_MIGR_01.DMP"
2023/03/22 12:45:25 DEBUG : Creating backend with remote "migration:migr-bucket"
2023/03/22 12:45:25 ERROR : : error reading source directory: directory not found
2023/03/22 12:45:25 DEBUG : S3 bucket migr-bucket: Waiting for checks to finish
2023/03/22 12:45:25 DEBUG : S3 bucket migr-bucket: Waiting for transfers to finish
2023/03/22 12:45:25 ERROR : Attempt 1/1 failed with 1 errors and: directory not found
2023/03/22 12:45:25 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 1 (retrying may help)
Elapsed time: 0.2s

2023/03/22 12:45:25 DEBUG : 4 go routines active
2023/03/22 12:45:25 Failed to copy: directory not found

I don't think that is what is happening. rclone copy doesn't create cache files normally.

What backend is migration:?

This error is normally quite straight forward - the source directory (or file) is missing. Did you typo /tmp/xxxxxx_MIGR_01.DMP?

The rclone was execute on Linux server. The directory and file exist on the specified location.
I did some more tests after posting this issue. I was able to execute this rclone on the Linux server as user1 fine without any issues.
When the same command gets executed from EM with a different use user2, we are seeing this issue. I have the sysadmin Team looking into the permission difference between user1 and user2 to see what's the difference and hopefully that could lead into find the missing access on user2.

I'll keep you, posted if I was able to make more progress with it.

Thank you and I appreciate you looking into it.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.