Soulseek sharing folder as remote

What is the problem you are having with rclone?

I'd like to mount a Google Drive remote folder and point Soulseek to it for downloading and sharing. I've set up the remote successfully and mounted the drive but the downloads always fail.

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: darwin/amd64
  • go version: go1.15.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Mac Mojave 10.14.6 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --vfs-cache-mode writes googledrive: /Users/jamesmorrison/Desktop/TEST 

The rclone config contents with secrets removed.

type = drive
scope = drive

A log from the command with the -vv flag

jamess-MBP:~ jamesmorrison$ rclone mount --vfs-cache-mode writes googledrive: /Users/jamesmorrison/Desktop/TEST --log-level DEBUG
2020/11/10 23:37:31 DEBUG : rclone: Version "v1.53.2" starting with parameters ["rclone" "mount" "--vfs-cache-mode" "writes" "googledrive:" "/Users/jamesmorrison/Desktop/TEST" "--log-level" "DEBUG"]
2020/11/10 23:37:31 DEBUG : Creating backend with remote "googledrive:"
2020/11/10 23:37:31 DEBUG : Using config file from "/Users/jamesmorrison/.config/rclone/rclone.conf"
2020/11/10 23:37:31 DEBUG : Google drive root '': root_folder_id = "0AGi5EqYR9kmxUk9PVA" - save this in the config to speed up startup
2020/11/10 23:37:32 Fatal error: Directory is not empty: /Users/jamesmorrison/Desktop/TEST If you want to mount it anyway use: --allow-non-empty option
jamess-MBP:~ jamesmorrison$ 

The directory you are trying to mount it to has files in it. You need to make sure it's empty.

Thanks for your response. I cleared and tried a new one which is empty but I still receive the other error:

2020/11/11 23:34:07 ERROR : Failed to create vfs cache - disabling: failed to make cache directory: make cache directory failed: mkdir /Users/jamesmorrison/Library/Caches/rclone/vfs: permission denied

2020/11/11 23:34:07 NOTICE: macOS users: please try "rclone cmount" as it will be the default in v1.54

That means you don't have permission to write to that directory. I'd guess you ran as root or another user which caused that? Unsure as you need to fix the permissions error.

Hi, I was wondering if you knew how to fix the permissions error? It looks like the user in this post had the same error: Please help Rclone mount on macos

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.