Please help Rclone mount on macos

about your mount command, did you try it?
is there something wrong with it?

the read only mount for streaming. which i mount on windows computer.
rclone mount gcrypt: g: --attr-timeout 1000h --dir-cache-time 1000h --poll-interval 0 --rc --read-only

then to prime the mount, to enable emby to quickly scan the mount.
rclone rc vfs/refresh recursive=true

Hello, thanks for the tips about vfs/refresh.
I'm on a mac too and experiencing very slow performances such as unable to use preview even for simple PDFs. Do you have such a behaviour?

i am not a macos user.

when dealing with a file browser,
i disable generating icons, previews and anything that will access the file.

Thanks, I've made a complete rework of my config using caches as found in animosity's work
Now everything is ok
Btw, I'll try this for getting more speed

jackiezhao@Zhis-MacBook-Pro ~ % /usr/local/bin/rclone cmount onedrive: /Users/jackiezhao/OneDrive

--allow-other \

--allow-non-empty \

--dir-cache-time 96h \

--vfs-cache-max-age 48h \

--vfs-read-chunk-size 64M \

--vfs-read-chunk-size-limit 2G \

--ifs-cache-mode writes \

--cache-dir=/Users/jackiezhao/RcloneCache \

--buffer-size 32M \

--umask 002 \

--log-level INFO \

--log-file /var/log/rclone.log \

2020/10/03 14:53:10 Failed to load config file "/Users/jackiezhao/.config/rclone/rclone.conf": open /Users/jackiezhao/.config/rclone/rclone.conf: permission denied

zsh: command not found: --allow-other

jackiezhao@Zhis-MacBook-Pro ~ %

jackiezhao@Zhis-MacBook-Pro ~ %

Zhis-MacBook-Pro:~ root# sudo /usr/local/bin/rclone cmount onedrive: /Users/jackiezhao/OneDrive \

--allow-other
--allow-non-empty
--dir-cache-time 96h
--vfs-cache-max-age 48h
--vfs-read-chunk-size 64M
--vfs-read-chunk-size-limit 2G
--vfs-cache-mode writes
--cache-dir=/Users/jackiezhao/RcloneCache
--buffer-size 32M
--umask 002
--log-level INFO \

2020/10/03 15:01:46 INFO : One drive root '': poll-interval is not supported by this remote
2020/10/03 15:01:46 INFO : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
fuse: unknown option `nonempty'
2020/10/03 15:01:46 ERROR : One drive root '': Mount failed
2020/10/03 15:01:46 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

hi,

https://github.com/libfuse/libfuse/releases/tag/fuse-3.0.0

i installed osxfuse already

did you remove --allow-non-empty and test?

if so, what is the problem now?

2020/10/04 03:27:32 DEBUG : Creating backend with remote "onedrive:"

2020/10/04 03:27:32 DEBUG : Using config file from "/Users/jackiezhao/.config/rclone/rclone.conf"

2020/10/04 03:27:33 INFO : One drive root '': poll-interval is not supported by this remote

2020/10/04 03:27:33 DEBUG : vfs cache: root is "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:27:33 DEBUG : vfs cache: metadata root is "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:27:33 DEBUG : Creating backend with remote "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:27:33 ERROR : Failed to create vfs cache - disabling: failed to make cache directory: make cache directory failed: mkdir /Users/jackiezhao/rclone_cache/vfs/onedrive: permission denied

2020/10/04 03:27:33 NOTICE: macOS users: please try "rclone cmount" as it will be the default in v1.54

2020/10/04 03:27:33 DEBUG : One drive root '': Mounting on "/Users/jackiezhao/onedrive"

2020/10/04 03:27:33 mount helper error: mount_osxfuse: mount point /Users/jackiezhao/onedrive is itself on a OSXFUSE volume

2020/10/04 03:27:33 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64

Zhis-MacBook-Pro:~ jackiezhao$

please try "rclone cmount"

mount point /Users/jackiezhao/onedrive is itself on a OSXFUSE volume

2020/10/04 03:32:47 DEBUG : rclone: Version "v1.53.1-DEV" starting with parameters ["rclone" "cmount" "onedrive:" "/Users/jackiezhao/onedrive" "--allow-other" "--allow-non-empty" "--dir-cache-time" "96h" "--vfs-cache-max-age" "48h" "--vfs-read-chunk-size" "64M" "--vfs-read-chunk-size-limit" "2G" "--vfs-cache-mode" "writes" "--cache-dir=/Users/jackiezhao/rclone_cache" "--buffer-size" "32M" "--umask" "002" "-vv"]

2020/10/04 03:32:47 DEBUG : Creating backend with remote "onedrive:"

2020/10/04 03:32:47 DEBUG : Using config file from "/Users/jackiezhao/.config/rclone/rclone.conf"

2020/10/04 03:32:47 DEBUG : One drive root '': Token expired but no uploads in progress - doing nothing

2020/10/04 03:32:47 DEBUG : onedrive: Loaded invalid token from config file - ignoring

2020/10/04 03:32:50 DEBUG : onedrive: Saved new token in config file

2020/10/04 03:32:50 INFO : One drive root '': poll-interval is not supported by this remote

2020/10/04 03:32:50 DEBUG : vfs cache: root is "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:32:50 DEBUG : vfs cache: metadata root is "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:32:50 DEBUG : Creating backend with remote "/Users/jackiezhao/rclone_cache/vfs/onedrive"

2020/10/04 03:32:50 ERROR : Failed to create vfs cache - disabling: failed to make cache directory: make cache directory failed: mkdir /Users/jackiezhao/rclone_cache/vfs/onedrive: permission denied

2020/10/04 03:32:50 DEBUG : One drive root '': Mounting on "/Users/jackiezhao/onedrive"

2020/10/04 03:32:50 DEBUG : One drive root '': Mounting with options: ["-o" "fsname=onedrive:" "-o" "subtype=rclone" "-o" "max_readahead=131072" "-o" "attr_timeout=1" "-o" "atomic_o_trunc" "-o" "noappledouble" "-o" "volname=onedrive" "-o" "nonempty" "-o" "allow_other"]

fuse: unknown option `nonempty'

2020/10/04 03:32:50 ERROR : One drive root '': Mount failed

2020/10/04 03:32:50 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

i mentioned a few times, remove --allow-non-empty from the command.

it worked when i remove non empty thx ..
but im still lagging playing 1080p videos

do a speed test and post the results.

post you mount command.

how to do a speedtest ?

can you play 720p without lag?

i stream it on a vidoe player not plex or emby

can you stream 1080p using video player, not using plex or emby?

https://www.speedtest.net/
image