[SOLVED] Trouble Mounting GDrive On Local Server

Hi everyone,

New to the forum so please be gentle.

I used rclone to mount my GDrive to my VPS (Ubuntu) so I could use Plex and it worked great. I was able to see all my files. Now I am trying to mount GDrive to my local home server (CentOS 7) and am having trouble. I used the exact same steps as I did for VPS, but when I ‘ls’ my GDrive directory nothing shows up. I tried while firewalld was enabled/disabled so it doesn’t seems to be a firewall issue. FUSE is installed. I even tried to manually input clientID/clientSecret in rclone.conf but that didn’t work either. Does anyone have any ideas as to why I cant get this mounted?

Mind you that my GDrive is GSuites.

Here is the script I use to mount GDrive to my VPS. If you need any other info, please let me know and I will happily provide it. TIA

Description=Mount Google to /mnt/Google
After=syslog.target local-fs.target network.target

ExecStartPre=-/bin/mkdir /mnt/Google
ExecStart=/usr/sbin/rclone mount \
  --config /home/<username>/.config/rclone/rclone.conf \
  --read-only \
  --allow-other \
  --allow-non-empty \
  --buffer-size 64M \
  Google:/Files /mnt/Google
ExecStop=/bin/fusermount -u //mnt/Google
ExecStop=/bin/rmdir /mnt/Google


Apologies. Apparently the script I have was not pointing to the correct directory where I had rclone (/usr/bin not /usr/sbin). I know it was something stupid and easy.

Problem solved. You can close this thread.