SOLVED - New remote always returns "failed to save config file"

What is the problem you are having with rclone?

Installed RClone on Zorin OS for family PC, everything's OK. Tried to create a remote with OneDrive, get the same message "Failed to save config file: open /home/username/.rclone.config" over and over. Installed GO to be sure. Tried to apply solutions found in post 15529, but to no avail...

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Zorin OS 15.3

Which cloud storage system are you using? (eg Google Drive)

Microsoft OneDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

File doesn't exist.

A log from the command with the -vv flag

Where's this logfile?

Thanks in advance for any help!

Dinosaurs used the version you are on. You want to upgrade that.

If you don't have permission to write to your home directory, you get that error.

1 Like


I've installed this version following the original site instructions, maybe it (the site) should be updated... By the way, will rclone upgrade with the basic Linux commands or is there any special procedure?
Besides, I suppose that a fresh Linux installation should allow any user to write in his Home directory, shouldn't it?

Thanks for the quick answer!

the only reliable way to update rclone is this

What are the original site instructions? Can you post a link to what you followed?

Yes, if you are running as the same user, you should have permissions. You'd have to share some details if you want to troubleshoot that.

Looks like I'm not a dummy, but a dumby... :man_facepalming:

Thanks guys, the normal install is now successful! Case is closed...

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.