(Solved) Impossible local download from Dropbox

What is the problem you are having with rclone?

I had a GDrive storage mount with an associated crypt. I used rclone sync to create an exact copy of it on Dropbox. Now I have both identically encrypted Gdrive and Dropbox mounts. However when I try to mount the crypt Dropbox drive ("crypt-db"), I can see any decrypted files but can't locally play or copy any file. Same with the encrypted files (when I mount "plex-db").

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: darwin 11.5.2 (64 bit)
  • os/kernel: 20.6.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.17.9
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Workspace Business
Dropbox Advance (unlimited storage for 3 users / month)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync plex-gcp: plex-dropbox: -P --checkers 12 --log-file /home/user/rclone_gdropbox.log -v --tpslimit 12 --transfers 8 --max-transfer 9500G --drive-chunk-size 32M --user-agent="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36"

That was for the sync, below the local mount of the Dropbox crypt:

rclone cmount plex-db: ~/test-dropbox -vv --vfs-cache-mode writes

I tried without the --vfs-cache-mode writes too, same result

The rclone config contents with secrets removed.

type = crypt
remote = plex-gcp:/
filename_encryption = standard
directory_name_encryption = true
password2 = SAMEPASSWORD2

type = crypt
remote = plex-db:
filename_encryption = standard
directory_name_encryption = true
password2 = SAMEPASSWORD2

type = drive
client_id = ******************.apps.googleusercontent.com
client_secret = ************************************
scope = drive
token = {"access_token":"ya29.******************-X8DD-nLGCs71zft0X7CHeEp1TToLX2C4YEg9XUaDjuBUVyRBkWZTuIP-wEiJvunLnAooYVbjMk3sbenmIZmfoQ4AjpMVmjktCTNWmGOO6QHAoe2Qg","token_type":"Bearer","refresh_token":"1//******************-L9IrRAotHtzgOhMV6_tLugy97K7-cldwvwfIwqKVrFGZBpKHDoU0BQNT4niAoqpE2AlKQbo","expiry":"2022-05-30T14:24:26.011526+02:00"}
team_drive = 

type = dropbox
client_id = ******************
client_secret = ******************
token = {"access_token":"sl.******************************************************Bdkf0Z2VnMzJX-07en9hL8RmFKxHtA2eOTxfraoa1PpTooNGSm0IDWfhYzvi","token_type":"bearer","refresh_token":"-******************************************************","expiry":"2022-05-30T18:00:15.010909+02:00"}

The Dropbox app console config contents.

A log from the command with the -vv flag

Sorry, I couldn't post on pastebin since the log is too long.

N.B: Trying to read the file "Mr Robot - Digital currency.mov"

Error message from Finder when I try to copy/read video file

The Finder can’t complete the operation because some data in “Mr Robot - Digital currency.mov” can’t be read or written.
(Error code -36)

Any help welcome, thanks in advance.

There's no read attempt in the log at all.

Are you running as the same user? Did you try with --allow-other?


I guess I've found "a" solution, may be not the best one.
Basically, I deleted "plex-db" while leaving the "crypt-db" on and deleted the associated app on Dropbox.
Restarted from scratch with rclone config, but this time, on top of adding the URI "http://localhost:53682/", I marked all options in the Permissions tab (all the ones that appear under Account Info). I cleaned my browser's cache and dropbox cookies, got the authorisation window to connect rclone to dropbox, validated it. Then when I tried to cmount "crypt-db" I could finally get access to my decrypted files and read them.

Sorry for the long post, happy to hear your thoughts on it.

It was the same user, tried with --allow-other. Same issue. Found a solution though below. Take care.

There's nothing to indicate in the log. you had any permissions issue on the app registration.

Did you not have that before? You can't get a token if that is wrong and it won't authenticate.

I had, I diligently followed the guide.
And strangely the authentication worked the first time, but I couldn't play nor download any files.
I did what I indicated previously and it seems to have fixed the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.