[Solved] Google drive shortcut folder does not appear

What is the problem you are having with rclone?

I am trying to download a folder that was shared with me. I tried to create a shortcut in my drive, let's say in my gdrive:folder/link.

Now, when I do rclone lsd gdrive:folder, the folder appears empty, instead of showing the shortcut as a folder (this is what I expected by reading the documentation).

Is this expected, since the folder does not belong to me, but was being shared with me ?

What is your rclone version (output from rclone version)

rclone v1.49.0
- os/arch: linux/amd64
- go version: go1.12.9

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Description: Debian GNU/Linux bullseye/sid
Release: testing
Codename: bullseye

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy gdrive:folder/link local_folder

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

$ rclone lsd -vv gdrive:folder

2021/02/24 12:12:11 DEBUG : rclone: Version "v1.49.0" starting with parameters ["rclone" "lsd" "-vv" "gdrive:folder"]
2021/02/24 12:12:11 DEBUG : Using config file from "/home/<redacted>/.config/rclone/rclone.conf"
2021/02/24 12:12:12 DEBUG : data: Ignoring unknown document type "application/vnd.google-apps.shortcut"
2021/02/24 12:12:12 DEBUG : 5 go routines active
2021/02/24 12:12:12 DEBUG : rclone: Version "v1.49.0" finishing with parameters ["rclone" "lsd" "-vv" "gdrive:folder/"]

Actually I just updated rclone, and this was solved in 1.51. Thanks for your awesome work !

Even that version is more than a year old. The latest version is 1.54.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.