[Solved] Google Drive access error: my account does not have access to Cloud Shell 3212398

While setting up rclone to connect to my google drive in my G Suite(yea, I chose 9 Google Drive rather than 8 GCloud Storage in the newest version of rclone), I always get an error saying:

Error: Unauthorized
You are currently logged in as [my gsuite account email address] which does not have access to Cloud Shell 3212398.

I googled and didn’t find any direct solution. I am trying to move my data from ACD to GDrive. It’s urgent since Amazon probably will purge my data soon. Any solution?

Thanks in advance! I’m kinda freaking out since I don’t know when my data will get deleted by ACD and I have 33T to transfer…

In your .rclone.conf file what is the type specified for the remote you are using?

Thanks for your prompt reply calisro!
I’m actually using rclone for the very first time. I used rclone --config to find the path of that file and did “nano /home/myname/.config/rclone/rclone.conf” and got a blank page. Right now I’m just stuck with adding google drive as my first remote.

I solved this by choosing “no” at auto config and copied the auth address directly to my browser and it works now. Thanks for your support! :slight_smile:

Ah. Did you maybe have two accounts authorized in that browser session?

I later realized that it might be a remote config thing since I met this problem when I tried to config it on Google Cloud Platform, and later when I configure Amazon Drive Proxy on my local machine, I tried to configure Google Drive again and it works seamlessly on my local browser haha!

By the way, do you happen to know what “0% done, 0 Bytes/s, ETA: -” means to a file? I have so many tiny encrypted files showing this information and I am worried if those files got filed to transfer or something. Screenshot: https://imgur.com/a/eBhdj

I’ve also posted a question here: What does “0% done, 0 Bytes/s, ETA: -” in “rclone copy” mean to a file?