[Solved] Fatal error: mount not ready when mounting remote server via SFTP

What is the problem you are having with rclone?

I cannot mount to a remote server's folder. I connected to it via SFTP. I can copy and ls files in the target directory, but not mount. I tried to mount from two separate servers, and both gave similar logs.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: 5.4.0-66-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Cloud Shared VPS running Linux

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount box:downloads/apps/ apps --daemon --allow-other

The rclone config contents with secrets removed.

type = sftp
host = host
user = username
key_file = /home/user/.ssh/private_key
md5sum_command = md5sum
sha1sum_command = sha1sum

A log from the command with the -vv flag

2022/02/12 00:01:19 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "mount" "box:downloads/apps" "apps" "--daemon" "--allow-other" "-vv"]
2022/02/12 00:01:19 DEBUG : Creating backend with remote "box:downloads/apps"
2022/02/12 00:01:28 DEBUG : Using config file from "/home/username/.config/rclone/rclone.conf"
2022/02/12 00:01:29 DEBUG : sftp://username@host:22/downloads/apps/: New connection src-ip:54348->dest-ip:22 to "SSH-2.0-OpenSSH_7.9p1 Debian-10+deb10u2"
2022/02/12 00:01:30 DEBUG : sftp://username@host:22/downloads/apps/: Using absolute root directory "/home/username/downloads/apps"
2022/02/12 00:02:30 DEBUG : sftp://username@host:22/downloads/apps/: closing 1 unused connections
2022/02/12 00:02:30 DEBUG : Daemon timed out. Terminating daemon pid 596021
2022/02/12 00:02:30 Fatal error: mount not ready

hello and welcome to the forum,

can you test without --daemon

Thank you for the quick reply. Without --daemon, I do see it working with -vv. What would be the better way of doing it? Should I use screen instead? Am I using the daemon command improperly?

there are lots of post in the forum about issues using rclone mount + --daemon
and there is https://github.com/rclone/rclone/issues/5664

sure, can use screen, tho i use tmux.

and as per the rclone documentation, there are a number of ways, including but not limited to systemd.
also, can use cron,

Thank you. I have marked the problem as solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.