Snap Rclone 1.36 Error (Dropbox) Failed to ls: couldn't list: v1_retired

I finally managed to get rclone working on my VPS via Snap (had to install with --devmode due to Snap's security protocols) and configured to access my Dropbox account but when I run the command:

rclone ls remote:

I get this error:

Failed to ls: couldn't list: v1_retired

Rclone version 1.36
OS: Ubuntu 18 (remote VPS, headerless)
Storage: Dropbox
Command: rclone ls remote:
Log (-vv):

2019/10/29 12:06:10 DEBUG : rclone: Version "v1.36" starting with parameters ["/snap/rclone/466/bin/rclone" "-vv" "ls" "remote:"]
2019/10/29 12:06:10 INFO : Dropbox root '': Modify window not supported
2019/10/29 12:06:10 Failed to ls: couldn't list: v1_retired

1.36 is many, many years old.

Please download the latest version.

https://rclone.org/downloads/

1.36 doesn't support the v2 protocol at dropbox. You'll have to upgrade - I suggest the latest release.

If you want to set up remotely check out: https://rclone.org/remote_setup/ for methods on how to do it.

But 1.36 is the only one that seems to be packaged as a Snap install?

Also I did try installing the latest version via the install script (1.5?) but the config script fails because I'm running on a headerless VPS and it hangs waiting for a browser response (Dropbox authorization) because there's no browser. The URL response part works OK in 1.36 because it is a URL you can copy and paste into any browser (different computer) whereas the 1.5 URL uses localhost (127.0.0.1) which won't work because the host computer has no GUI/browser.

You might find this helpful with 1.50 :slight_smile:

Thank you! :slight_smile:

Got it working now. Not sure what was happening before but I did try the remote authorization on my Mac and it kept failing. This time it worked!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.